Ubuntu 18.04 - No Sound In Menu and Cores (Snap Version)


#1

Hi,

I’m running the Snap of Retroarch on Ubuntu 18.04 (Unity desktop) on a Core i3 system hooked up to my television.

Sound does not work anywhere within Retroarch (no clicks when moving through the main menu and no sound in ROMs - tried multiple cores: NES, SNES, PC Engine, N64…).

Launching Retroarch from the terminal, I get the following error:

ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: Operation not permitted

Is this perhaps related to the Snap package being sandboxed? :thinking:

The sound is output over HDMI on an NVIDIA GeForce 750 Ti and is working fine elsewhere in the system (web browsers, Kodi, VLC, etc.). I’m using nvidia-driver-415.

I’ve tried both the deb from the Libretro PPA as well as the Flatpak but both had issues recognizing input - to move through the RA menu, I had to mash the arrow key 8-10 times for each movement (something weird bug related to polling?). Input works as expected in the Snap version, but there’s no sound.

Under Settings > Audio > Devices, I have no devices available to choose from (it’s blank). This is also the case on my laptop, though, and sound is working fine there (using deb version).

That said, I followed the suggestion here and tried every device listed in the output of aplay -L to no avail. I can post that output if anyone would find it helpful, but I’m thinking it’s a dead end.

I’ve been beating my head against this issue for a few weeks now and I’m running out of ideas - I’d really appreciate it if someone could point me in the right direction!


#2

Have you updated your snap lately? There was an issue with sound when 1.7.6 first landed, but it should be resolved now.


#3

Yup - that fixed it!

Thank you very much! I’ve been updating my packages manually through apt but I was missing Retroarch each time since it’s a Snap - I’ll have to keep that in mind going forward!