Unable to remap controls - MC-Cthulhu

I am unable to rebind any buttons in 1.7.7 fresh install on a fresh windows 10 64 bit. The controller is a MC Cthulhu and works fine as X input and D input. The major issue is when I start a game and try to remap the buttons inside the quick menu. Retroarch absolutely refuses to allow any changes from the default binding. In earlier builds I could do it without issues. Any help would be well appreciated. Apologies if this a hijacking the thread.

In the quick menu > controls menu, are you pressing left/right to cycle through the functions?

yes on the controller and the keyboard What is strange is that the option normally had “retropad” beneath the options to change the button. Now it says the name of the controller instead.


Update: It appears I am unable to remap any controllers on 1.7.7 Just tried an Xbox 360 wired and I was unable to remap the controller in the quick menu for the game

which cores have you tried?

Currently FBA CPS1 is the only core I have tried.

Yeah, that was just a bad draw. Unless you’re on a terrible potato-machine, you should generally use FBNeo or MAME (without a year after its name)

FBNeo works really well with arcade sticks and supports remapping, while MAME has the MAME OSD menu for remapping.

Update: Looks like the core FBA 2012 CPS-1 is unable to remap anything. I have attempted 6 different games and all of them refuse to remap. Looks like this is a fault within the core itself. All other cores can remap perfectly. Admins may want to move this to The FBA 2012 CPS-1 section of the forums so appropriate attention can be brought to this.

yeah, that’s known, actually, and why I asked which cores you’ve tried. Those are essentially dead cores that only exist for potato-caliber hardware, like Wiis.