Using vJoy in Retroarch = Mouse Ball for Arkanoid

It seems i have come as far as my intelligence ( currently ) takes me:

I have set up the vJoy Driver so that Windows will recognize my Mouse as a Joystick

Both Buttons work as per the Windows Game Controllers menu:


The system is Run by the UCR/AutoHotKey Script as follows:

And all i want to do is to get Retroarch to Accept this vJoy ( Buttons & Movement / left&right ) as the vJoy that i want to use.

It is in Port 1 and can be seen in Retroarch:

Opening up Arkanoid brings up this:


Yet i can see it in Retroarch as the option, in the correct Port 1:

Can you ( divine gamer minds ) help me get the vJoy working also in Retroarch, and not only in the Windows Game Controllers menu ?

If you go into the menu while in game, and go down to “controls” you should be able to switch it to “Mouse(full)”.

This allowed me to play Arkanoid with my mouse - did not need any extra program to set it up as such.

Since it’s not configured, you’ll need to create an autoconfig profile for it in settings > input > port 1 controls. First, hit ‘reset to default controls’ and then go down to the buttons you want to map, hit ‘enter’ on your keyboard and it will pop up a dialog box where it listens for inputs. Do whatever action on your mouse will trigger the event and then move to the next button and do the same process (I assume you’ll want left-click to be retropad-B and right-click to be retropad-A or vice version as is your preference).

Once you have your stuff mapped, hit ‘save controller profile’, then ‘reset to default controls’ again. Now close RetroArch and then reopen it and it should be working as a gamepad. NOTE: you should probably also go to settings > input > menu controls and enable “all players control the menu”, in case your mouse-turned-controller grabs P1 unexpectedly.


The OP is using a version of the FinalBurn core which is several years old, the “Mouse (full)” device type might or might not be available in that version.

It will work with the latest version of the FinalBurn core, aka FBNeo.


Thank you very much, for some reason when i go to select mouse, it gives only a few options like this ( and the buttons can not be configured / do nothing )

Thank you, i downloaded the latest Retroarch ( i believe ) and FinalBurn Neo ( i believe should be the latest )… And i see the mouse ( Full ), but it does nothing with the Mouse after selecting ( in Arkanoid ), and i would need to understand what i am not doing right.

Thanks again

addition: The Mouse buttons work as Fire and Release the Ball, but mouse left to right is not registered to move the Ark( anoid ? )… and no credits can be loaded or Start button pressed via mouse ( which is weird, since it works as release the ball and fire, but nothing else moves nothing yet )

I appreciate your help, and thank you again ( for all the tips )

I noticed ( a weird thing ) when i load the FinalBurn Neo core… it shows it in retroarch, then when i load the game it loads FBAlpha… and i am not sure which core is active actually

The core in use is the one you’ll see at bottom left corner of retroarch menu.

Also, you removed your vJoy thingy, right ? I don’t know if your mouse will be properly recognized as a mouse by the core if you are transforming it into a joystick through some weird 3rd party tool. You also need to make sure the proper Mouse Index is set at Settings > Input > Port 1 Controls

Also never set that “Analog to Digital Type” crap, FBNeo doesn’t need it, it might even be harmful.

Thanks i removed the vJoy thing

And i am not sure what is going on, but when loading the game with the FinalBurnNeo Core, retroarch crashes

The core works properly so i can only guess you have some kind of retroarch setup issue. I’d recommend a fresh install of retroarch if you can’t figure it out.

1 Like

Hi there, Thank you everyone ( Divine Gamer Minds ) again

I tried with a brand new install, and i am able to open the game - but it has a weird issue where the mouse buttons do nothing. ( and there seem to be no options to ‘config’ these buttons when selecting Mouse Full )

How can i get the mouse buttons operating ?

Retroarch remapping is kinda limited because it lacks flexibility, it only really works with gamepads (and lightguns somehow). Once you add mouses or keyboards it becomes a mess and it’s even worse with hybrid controls which are kinda common in arcade setups.

I believe your problem here is that you didn’t find coin & start keys : fyi only the game buttons are mapped on the mouse when using “Mouse (full)”, coin & start will stay at their usual location, meaning on the gamepad if you have a gamepad connected for that player, and on your keyboard where their default mapping should be shift & return for player 1 (i don’t know for player 2 so don’t ask me).

… with Selectable controls in 2020 to play games ?

Been trying to play arkanoid for couple years with mouse or map mouse to work…

Mouse ( FULL ) does not have any mapping for buttons, so it is definetely not full mouse mode - unless i am missing something

( just need the mouse buttons to work for coins, and moving mouse left to right to move left to right… seems to work at random, what am i doing wrong, what do i need to know )

All other windows programs recognize the mouse

How can i use mouse 1 for player 1 and mouse 2 for player 2 with mouse buttons for coin and start on arcade emulation ?

Hi there everyone,

So i am on my quest of finally getting the Arkanoid working with a Mouse ( and then after that 2 mouse’s ).

When choosing the Mouse Full ( using Finalburn Neo ), the mouse buttons do nothing ( logitech G502 )

How can i fix the buttons ? Any specifics i need to check or something ?

Just asking because i see quadzillions of topics that go nowhere, and i think this is ‘basic’ in emulation… like something everyone would definetely need -> Easy set up of Mouse, as any other controller.

And i am trying to set up Arkanoid with the mouse - been working on this for 5 years… please assist, lol ( no really… do i need to learn to code before i can game or whaat ? ) :slight_smile:

1 Like

Sorry, I meant to post my reply to this thread and not your other one

If you go into the menu while in game, and go down to “controls” you should be able to switch it to “Mouse(full)”.


Thank you very much, for some reason when i go to select mouse, it gives only a few options like this ( and the buttons can not be configured / do nothing )

1 Like

Stop opening new topics about this, it’s starting to look like spam, you were already answered about this in the first topic : retroarch doesn’t handle mouse remapping, nor any kind of hybrid remapping (remapping one kind of device to another, remapping players whose controls are split on several devices, …).

If you need hybrid remapping, you’ll need to use a MAME core and its builtin MAME OSD.

Edit: i merged all those duplicate topics together…