Virtua Tennis 2 NAOMI Vulkan Flycast , black shade during replays

hi members and devs , i’m just reporting a small issue with Virtua Tennis 2 NAOMI when using Flycast. When there is a replay after a point is won the screen turns rather dark , the GFX are still visible only there is a shade of black in the image.

it occurs on both my MAME PC and Bedroom PC , they both have AMD GFX Cards. Also the problem doesn’t happen when using GL only in Vulkan.

chat soon

There’s also an issue with replays on the DC version. On my side, it stutters a lot with Vulkan (Win10).

Maybe it’s related ?

it’s been a while since i’ve played the DC ver on real hardware but from memory there was some slowdown in the replays. Maybe someone can confirm that.

This should be fixed with the next build (39026c0). It also fixes the missing Naomi logo at boot.

1 Like

that is awesome flyinghead thank you , can’t wait for the next release. And yes there is a NAOMI logo issue that has popped up in the last week or so , great to see it being worked on.

Virtua Tennis 2 running on my Vewlix Clone

https://www.youtube.com/watch?v=5Bkng6JWhhM&t=1s

hi flyinghead , just tested (39026c0) and the NAOMI logo on boot has been resolved which is neat. Unfortunately the black issue on replays still lingers in Vulkan. I tried GL and it is running well without the issue , if you need any info of my GFX card settings or anything like that let me know. There’s no rush take it easy

There might be another issue then, possibly specific to your video card.

The issue I fixed was happening in per-triangle mode only, for both GL and Vulkan. During replay, some frames would be completely blacks, resulting in a “blinking” screen effect.

Can you check if your problem happens in per-strip or per-pixel mode? Do you have Threaded Rendering on? Synchronous Mode? If not try to enable both to see if it make a change.

Thanks

hi again , i tried a few different things and grabbed some screenshots in Retroarch. ok there was 2 problems but one has been fixed about 6 days ago. Simply the NAOMI logo wouldn’t show and i would get GFX that cut out to a black. I think this was the blinking issue you mention of , this was fixed. It popped up about 10 days ago and was fixed about 4 days later.

the issue i mentioned when first creating the thread is still present on both my MAME-PC and Bedroom PC. My GFX Cards are AMD RX 570 and AMD 7850. My usual settings in RA are…

-Per-Triangle ON -Threaded Rendering ON -Synchronous Mode ON

I also tried the following on my Bedroom PC…

-per-strip or per-pixel mode -Threaded Rendering OFF/ON -Synchronous Mode OFF/ON

pics of the issue…

MAME-PC

Thanks for the screenshots, this is very helpful. It could be an issue specific to AMD cards.

I happen to have one sitting on my desk so I’ll do some tests with it.

I also have an AMD card with latest drivers and i was getting some black textures with some games, but disabling mip-mapping fixed it.

just bumping this Thread as the issue still remains in Flycast core in Retroarch. I don’t mean to be rude or pushy but Flycast is my go to for NAOMI DC and Atomiswave. So to make it even better and accurate , breakdown small issues a few games have.

I don’t know what’s going on with Flycast core development. Seems there is a core update available quite frequently which is good yet no bugs get fixed. Virtual Tennis still crashes in the intro, Trigger Heart still has a 5 second delay when you hit the keys. It seems like it’s being worked but it’s probably core changes as end users we can’t see.

thanks for chiming in trnz , roger that on the info you provided it’s good to know.