Way to start Beetle PSX without disc

Is there a way to start Beetle PSX without a disk so I can manage memory card saves? I had to create a new save to quickly grab a retro achievement I missed. Now that I’m done with it I’d like to delete that save while keeping the other saves, but there doesn’t seem to be a way to do that from the in game menu. I tried using load content to load the PS bios, but I couldn’t load the .bin file with Beetle PSX.

Have you tried just Loading the Core?

Start a game and immediately go to “Quick Menu - Disc Control” and eject your disc.
Then resume the game and it will boot into BIOS, where you can modify memory cards.

(You must have the “Skip BIOS” option disabled)

2 Likes

As an aside, you can also set, in core options, to where it saves separate .srm files for each game instead of a single ‘memory card’ file.

I am new to RetroArch and am also having issues getting this to work. Using Beetle PSX HW and RetroArch 1.12.0 (newest version to date). I’m just trying to get into the Playstation memory card manager. Thanks in advance.

  1. How do you just “Load the Core” as DaveTheMan suggests?

  2. I load my core, then my content which fires up after selection. I get to the menu using F1 right away (before logos show up), Go to Disc control, click eject disc (which creates a new menu item “current disc index”, then hit f1 again to return to the disc load and it just freezes. What am I missing?

  3. I have read to disable the “skip Bios” option. But noone describes where that is. Where is it?

  1. some cores have a ‘start core’ entry on the main menu if they can load without content. I don’t know if beetle-psx is one of them, but I don’t think so.
  2. after you go back in there and it freezes, go back into the menu and ‘reset’. This a soft reset, akin to pressing the reset button on the console.
  3. it’s in the quick menu > core options submenu, which you can only reach while content is loaded and running.

Appreciate the quick reply. You are correct and I do not see the “start core” option. Too bad that would make it real easy, so that option is out.

So I was able to get in and here’s how; It would seem that RetroArch disables the bios by default to save on resources. With the bios disabled it also skips the playstation logo boot screen. This needs to be enabled to get to the playstation default manager.

  1. Launch a game then get into the menu (F1 or file bar).
  2. Navigate to main menu > quick menu > core options > system >
  3. Turn “Show BIOS Boot Logo” to on. I did not see a “skip bios” option but I believe this is the same setting renamed. Basically it turns on the old playstation logo startup.
  4. From quick menu restart (soft reset) your game.
  5. When you see the playstation logo boot up, navigate to quick menu > disc control > eject disc
  6. Press F1 or resume from the quick menu.
  7. Voila, you are in.

Thanks hunterk for the help. You pointed me in the right direction. I hope this helps someone else NOT spend as many hours on this as I did.

1 Like