Where are mame reset/service gamepad binds configured

I’ve noticed that when I run mame2014 core on windows retroarch, using 360 gamepad, L3 opens the service menu and R3 resets the game. When i check mame configs (via tab key in game), it looks like keyboard F2 should open service mode, but I see no reference to the gamepad reset. It’s a bit of an issue, as I like to use the analog sticks as d-pads, but then I accidentally will hit L3, interrupting the game. Is there a way to disable the gamepad-mame-service setup that I haven’t found?


Yeah, remap Menu in the MAME general input menu to some other key or disable it by pressing Delete when you have the menu input highlighted. L3 and R3 are hardcoded to act like keys instead of joypad inputs in the MAME cores, so the only way to disable or change them is through the MAME input menu.

Thanks Awakened, I’ll try that. Some serious trivia there! I’ve been thinking of dipping my feet into retroarch dev; maybe looking into removing the hardcoding would be worthwhile.

It was probably done because originally the core didn’t have RetroKeyboard support. So RetroPad buttons had to be hardcoded to send those key inputs so you’d have a way to get into the menu. Since the core can read key inputs now using the RetroKeyboard api, the hardcoding probably isn’t needed. If R2, R3, L2 and L3 were set to be joypad buttons like the four face buttons and shoulders are, users could still go into the menu and set them to open the menu or whatever again if they want.

I am having a similar issue with controls and cannot figure it out. My issue is I use a keybaord to map my controls for my joypad so I have keys like WASD, A,B,X,Y etc. Well, even though I map my keys through retroarch, when I launch MAME2014, my keys do not stick from what I set in Retroarch. I hit TAB and set them manually but as soon as I close MAME2014, they keys revert back to default and I have to remap again.

Im having the same issue, my arcade stick opens the menu with one of the buttons and I cannot make the changes beign persistant. as soon as I close retroarch i need to configure everything again

Exactly the same issue with menu caused me to have different issue now. I entered the mame menu via the xbox controller and was trying to change the menu input to LT + RT. Somehow however I managed to reset it to None and exit the menu before I am able to realize my mistake. Now I cannot for the life of me show the mame menu, neither via controller, nor with keyboard (Tab doesn’t do anything). I already deleted the .cfg files I found in RetroArch folder and cannot find any other file with modified date today. Tried resetting RetroArch to default as well - didn’t help. Can anyone please explain how to get to mame core menu, so I can configure it right this time?

I think by default these settings are stored in the rom directory, in a “MAME” subdirectory.

Thanks for the reply, but I didn’t have anything in that folder. Wiping RetroArch entirely and starting fresh fixed it.