[3.6][pc] Mame Config

I’m running the latest “Arcade (MAME - Current)” core (0.237) and having issues using Service (F2) within the Mame GUI. If I change the key assigned, it seems to set the same value for Power Off. Is this a bug? The same also applies to Memory Reset and Power on (both using F1).


Help!!! My select button is no longer working in Mame, so I am now unable to navigate Mame’s GUI. I’ve had a look around the folders accessible via Samba but can’t locate any file that shows key re-mappings. Any ideas?



For key configuration in mame:
Launch game - press (TAB) - Input (general) - Other Controls

Per default (F1) is “Power On” and “Memory Reset” & (F2) is “Power Off” and “Service”

Note, you may want to disable/change (F1) and (F2) in RetroArch - Settings - Input - Hotkeys to avoid key conflicts

Is /saves/mame/cfg/default.cfg under /savefiles/mame/cfg or /configfiles/retroarch/saves? My saves folder is empty and savefiles only lists the pause key.

Yes, I have since disabled a lot of RetroArch’s hotkeys to avoid conflicts.


The folder where all the saveram files are.

You can check in Settings - Directory - Save Files for the right path.

1 Like

Thanks :+1:. Found this file under Arcade (rather than Mame) under Savefiles.


Are you sure that F2 should be assigned to “Service” and “Power Off”? Every time I press this key (Fn + F2) it is closing Mame. F2 has been removed from RetroArch, so there shouldn’t be a conflict.


No, i am not sure :grin: To be honest, i don’t have a clue. Maybe this is required by some games.
Can you tell me on which game this happens?

Why (Fn+F2)? If you are on a Laptop, this maybe could trigger some other function?

:laughing:. Occurs in Gradius 4 when setting the date/time when first run. I’m using a wireless mini keyboard. I’ll check in the standalone Mame, although this is 0.238.


pal pal pal pal pal pal you are!