3DO core with crt switchres....240p?

Ive been using 4DO standalone for 3do emulation for years. Ive recently setup a new pc emulation setup that uses a CRT tv and been trying to use as many retroarch cores as I can to take advantage of switchres.

Ive downloaded the 3do core in retroarch but cant get it to launch right on my crt. Ive noticed theres also no config folder file for this core in retroarch, so is it not possible to use this core with switchres on my crt?

yeah, to tell you the truth, I don’t know if this core does everything it needs for switching res. Probably a good idea to open an issue at the github repo and ask the author.

It’s been a hot minute since I played around with my CRT, but I plugged it into my build and pulled up 4DO. I was able to launch Gex and Road rash into 240p on CRTSwitchRes without issue.

You mentioned a config folder file for the core though, I’m not familiar. What do you normally do with that for CRTSwitchRes on your setup? We also might be on different systems, I’m on Windows 10, if it matters.

1 Like

Im also on windows 10. I dont remember ever enabling core over-rides but just enabling crt switchres in my retroarch config wasnt enough… I had to go into the config folder and edit nes,snes,tg16,sega,etc cores config files and enable switchres there as well, then switchres started working fine for me. With 3DO there is no config file for the core to enable switchres. But it not having a core config I would think it wouldnt look for a core over ride so i dont know. I was hoping it would force all games into 240p like the japanese system that had the switch on the actual console, but maybe im wrong and only a few games support 240p on 3do?

I suppose switchres just uses the internal res, meaning 320x240 in this case. That would actually be inaccurate then without any 240p switch enabling option like on the Japanese machines.

You can of course launch any content in 240p by just launching RA in a res like that, Switchres is strictly speaking not necessary just for low res output. I probably have to settle for that on my Linux Notebook, because I can’t get Switchres to work correctly, so back to xprofile and self generated modelines >_< Haven’t looked for any core-specific configs yet though, maybe that could help in a last-ditch effort.

My understanding is that the 240p/480i on 3DO is purely a hardware level thing. I think all games support both resolutions. I prefer 240p for my games, but I get the same result with 480i on SwitchRes, I just have to switch it in in the Quick Menu>Options depending on my preference.

You could always just ‘make’ a 4DO.cfg, and throw the crt toggle line in there, see if that works. Though I’m not sure why your other cores need this, mine is toggled from the main retroarch.cfg.

It’s hard to say for certain with alot of this though, like I have most things running great with switchres, but resolutions higher than 480 (Interlaced PAL games, for example) are kind of a nightmare to get working on my main computer, but it works perfectly on my other one. I can’t explain it.

I spent 2 to 8 hours a day editing config file values one by one and testing, edit,test,edit,test- for weeks! Dug out my sony crt from the basement to try a different tv, even bought multiple transcoders… I could not get switchres to work right. It would work in RA itself if i set video_refresh to 30 but once launched from launchbox or bigbox i would get out of sync signal. I tried everything and was about to recompile a 8 TB HDD! I asked for help on a dozen sites…noone could help. At the last minute I noticed config folder in retroarch and that each core had a switchres_ true/false option in the config files. I set one to true…and bam… It worked!

I dont remember ever setting core over-rides when I compiled the drive, and made sure over-rides were disabled in RA but that did the trick for me… Id give it a try.

SkyHighGam3r…Are you saying the 3do core has options to output 480i/240p in the menu? Im pretty sure I looked and didnt see an option

I pulled the core up to verify and … it’s gone! I know for a fact it used to be, so I double-checked the documentation on the site and it’s listed - so I know I’m not crazy. lol

  • High Resolution [4do_high_resolution] ( disabled |enabled)The default internal resolution is 320x240, but the output resolution is 640x480. This feature makes the system behave as if it has a 640x480 framebuffer.

There is a resolution selection option now, but it doesn’t include the 480 setting. I’m guessing something either was broken, or the feature was removed.

youd think the core would have to have a config file where it could be edited but i couldnt find one

I never have config files unless I tell it to create an override. If you do that it should make the folder and file for you, or you could just manually create it.

I must of accidentally created over-rides for most of my cores when I compilled my HDD a few months ago because most of my cores have one. How can I create an over-ride for this core so it creates a config file?

Should be Quick Menu>Overrides>Save Core Override

ill try it out thanks!

well nevermind. I forgot I couldnt even get 3do to run with the RA core, I was still launching from 4do standalone. I thought I got it working but guess not. Been messing with too many emulators etc so been scatterbrained. Downloaded the core but games wont launch from RA

ugggg… this was one of my favorite systems and had one back in the day and still have it. Wanted to experience the games in 240p

That option is for higher resolution rendering (like on Beetle or other Playstation emulators), it’s not really working like a progressive/interlace switch. I actually have a hard time coming up with games where you see the effect because so many games on the 3DO still seem to rely on 2D scaling, but check out Star Fighter for instance.

Do you have the BIOS setup for it? I think it needs at least one of the BIOS variants to run. Games also take a lot longer to load in for me than other cores, though I’m not sure why.

Hey since you have a real 3DO, let me ask you, when you turn the system on - does it do anything before loading the game? Like a BIOS boot sequence? Similar to Dreamcasts swirl or gamecubes logo?

I can’t even find a video of someone turning a 3DO on with a game inside it. Only ones of without a game. I haven’t been able to get my hands on real hardware yet.

Yeah the real hardware takes a little while to load as well and the 3do splash screen is what pops up first.

Ive put 3 different bios varients in retroarch system folder. I dont know why it doesnt work but standalone works just fine. I wonder if its because my 3do games arent in their own folder? They are all dumped in a single folder but all run fine from 4do standalone

So … I made some progress.

I couldnt figure out why the 3do core wouldnt run from my 8tb launchbox drive so I downloaded another instance of retroarch to my desktop. The bios either werent named right or working so found the bios in my launchbox hdd in emulators>4do and copied all those into the new retroarch instances system folder. It then would run but switchres wasnt working. So I created a core overide which gave me a folder “opera” and inside a opera config file.

I copied over the known working bios to my 8tb hdd and also moved over the opera config file.

Didnt work…

I noticed the opera config was blank so copied the contents of sega cd config to the opera file and saved it.

Didnt work…

I then remembered the opera config was inside an opera folder and that the config wasnt just placed inside the config folder on the other instance of retroarch I had running. So I created an Opera folder inside the retroarch config folder, and put the opera config file in there…

Bam… 3do in 240p goodness!!!

You were right, in RA quickmenu there is option for 240p or 480i.

So all looked great loading up way of the warrior in 240p untill I get into the game and all the gameplay is slow and audio is slow. Any ideas why this could be? It runs great from 4do standalone emulator but seems like half speed in retroarch core.

Another disappointment is… in bigbox I chose to launch from retroarch and it does nothing. In launchbox if I go to manage emulators and set retroarch for default for 3do…it reports that the core"4do.libretro" is missing.

Now Im not sure if this new “opera” 3do core is really 4do or some other “new” “opera” emulator… but either way, it seems launchbox is looking for 4do libretro instead of opera for some reason.

So, Opera must be brand spankin’ new 'cause I hadn’t heard of it and looking at the core updater list 4DO is completely gone. (I just reinstalled my ENTIRE computer today though too, so take this notion with a grain of salt) That being said it looks like it’s just a rebranded 4DO core, I’m guessing the name change was in line with what we’ve seen with Reicast and Mednafen being rebranded as Flycast and Beetle. I think I read somewhere that was at the request of upstream to help differentiate.

I don’t know ‘anything’ about LaunchBox as I use HyperSpin as my frontend. What I do know though is that with HyperSpin (and by extension, RocketLauncher) I have to specifically set it’s RetroArch settings to use a core it doesn’t expect. For example, RocketLauncher expects something like VBA_libretro, but I have to tell it the core file it should be pointing at it mGBA_libretro. I assume there’s something similar in LaunchBox, I just couldn’t begin to tell you where.

I’m actually not seeing the 480i option in Opera either though. Although, I’m ok with that. I’ll take 240p on this system for sure. I’m also not seeing the slowdown on my end with Way of the Warrior, I’ve got fullspeed and the music sounds great. I’ve actually never played this lol I’m digging the soundtrack.

I’m not sure what would be causing the slowdown, do you have any shaders running or anything downloading in the background? I had some CRAZY slowdown on N64 the other night and then I remembered I was downloading like 200GB to the same drive lol

got it figured out, had to go back into manage emulators and right click on “4do-libretro” and was able to change it to opera.

Sadly most the games I want to play have choppy sound or choppy sound + slow gameplay. Will have to go back to 4do standalone unless anyone knows any ways around this.

Way of the warrior is awesome, controls are kinda clunky but it was awesome back in the day. Alot of fatalities and secret characters to unlock as well.

Yeah maybe its my emulator pc… I dont know.

FreeDO and 4do/opera RA cores have these same slowed down issues for me but on the same system 4do standalone works fantastic. I had these same issues with these same 3do emulators on my much older arcade cabs pc as well and it was on win7

specs win 10 i5 2500k 16gb ddr3 amd r9 380

such a shame…these old games from my teens look fantastic in 240p on this 27" panasonic crt