[5.x Dev][PC] Lakka stops working after first boot installed on SSD

Hi, everyone!

I hoped not to make a thread here, but this exceeds me!

A little bit of background: I’ve built a spare parts computer, that ended up being an AM4 Athlon 220GE with 8GB of DDR4 and an AMD RX550 2GB GPU. Just for fun, I’ve installed Lakka wayland.x86_64-devbuild-v5.x-20240317-95029.

First boot after installation, no problem. But the system doesn’t show RetroArch, it shows an empty desktop with logo and a “1” top left. I figured out how to get back to RetroArch using Ctrl+Alt+F2. Once I access RetroArch I do some customization, ozone, vulkan, sound output, enable ssh, etc. Exactly how I like it. After some testing, I was really happy with the wayland Lakka, it worked better than the Generic, which was showing some video glitches, and the X11 version that has video signal stability issues with this card. It was with that happiness that I powered off the system to have a family dinner, so Lakka stores the “retroarch.cfg” to never boot again.

At this moment, after SYSLINUX shows his words, the screens go black, and the computer restarts. Removing the RX550 doesn’t help.

It’s a nightly build, I know, I already have my 4.3 running. This is just for fun and testing.

I’ll be here to test whatever you all come to mind. Thanks!

I thought I would give Wayland a go myself but seeing the same. Top left showing a “1” and the date/time in the top right. Ctrl+Alt+F2 (as you say) loads RetroArch but this needs to be done each time after reboot.

Is there any way to set the 2nd screen by default? I assume the “1” is referring to Ctrl+Alt+F1.


Hi, Graham!

Your installation still boots! You’re lucky. Mine doesn’t even bother to boot after 1st boot. And it’s not related to BIOS problems. Legacy and UEFI devices boot properly. Live XUBUNTU, UEFI Windows 10. I’ve also updated BIOS to the latest from MSI. No change at all.

Today we have a new nightly. Gonna check it right now.

Have tried the latest build (20240318) but the same results I’m afraid.


Yup… No luck with that one. Generic or wayland.

March 20th version, doesn’t have any x86_64 build.

The weird part of this, is that the this is GPT and boot partition seems to be EFI, but BIOS doesn’t even try to boot EFI it keeps detecting a Legacy boot.

No problems here with Generic x86_64 builds, just Wayland.

However, my environment may be slightly different as I run Lakka from a live USB and use the workstation primary as a file server (host for roms, thumbnails, system/bios, save states/files and remaps). Using MBR which seems to give me less issues.

Will keep trying the Wayland builds and hopefully one day, will run just as good as the x86_64 builds. I see there are also X11 builds, which I may also give a try.



This issue may have been fixed on April 9th. Could you please confirm with April 9th or later nightly build?

Thanks for the update. Have tested build 20240410 and all seems to be working now.


1 Like