Analog Shader Pack version 3 is HERE!


#21

That screenshot looks nice :wink:


#22

The first thing that stands out immediately is the errors in the blur functions at the end, unfortunately blur shaders seem to have issues with ATI cards, here is the same error logged discussed here. Do you have an ATI card?

What kind of GPU do you have? There’s a lot of Cg stuff, such as ddx/ddy, that only work on Nvidia cards (and maybe Intel, but definitely not AMD/Ati).

islogged do you have an Nvidia or ATI card? FYI the setting in the screenshot you asked about is “diamondglass” in the arcade section.

Unfortunately why blurs don’t work on ATI cards is above my paygrade. Maybe someone else could chime in?

As for the gamma issue, not every setting has a dark gamma, some settings are darker and more contrasted, some lighter, arcades I definitely added more contrast because I think it makes the image pop more, just depends on what I felt the setting should be for that particular preset. I didn’t try to keep a universal gamma setting among all. Also its tough to get a proper adjustment because not everyones monitor is calibrated the same.

If people are in agreement I can make a side version with a brighter gamma across the board, personally I find the 320px NTSC screenshot washed out with a dark grey BG instead of a true black and the color doesn’t pop, but to each their own.


#23

I do indeed have an ATI card! Maybe hunterk can tell us if there’s any kind of solution or fallback mode. Alternately, you could switch to the .slang format for Vulkan (which will be backported to GLSL as well, evidently) when enough of the shaders are ready for it, which would help reduce input lag overall. Cg shaders are a dead man walking - this isn’t intended as a criticism of you, since you’re not coding, just an observation of the difficulties with supporting a dead specification. slang shaders do have parameters set up properly, though, so if all the right shaders are ported over it should be fairly easy to paste in slang replacements for the current shaders.

[QUOTE=solid12345;44647]As for the gamma issue, not every setting has a dark gamma, some settings are darker and more contrasted, some lighter, arcades I definitely added more contrast because I think it makes the image pop more, just depends on what I felt the setting should be for that particular preset. I didn’t try to keep a universal gamma setting among all. Also its tough to get a proper adjustment because not everyones monitor is calibrated the same.

If people are in agreement I can make a side version with a brighter gamma across the board, personally I find the 320px NTSC screenshot washed out with a dark grey BG instead of a true black and the color doesn’t pop, but to each their own.[/QUOTE]

I’ve played the game on actual hardware before, back when I had access to a CRT. The 320px preset NTSC filter isn’t using any kind of CRT emulation filter (though you can use it with things like Royale, etcetera), so it looks iffy because there’s no phosphors or anything; it doesn’t change that the colors on your shader just…aren’t right. The background isn’t supposed to be black, that’s the whole problem. Pretty much every shader I tried (or was able to try) tended toward the ‘too dark’ end of the spectrum, although bright pixel art games make the flaw far less obvious. Here’s a shot from a straight, native resolution version without any shaders (enlarged 2x for clarity):

I’m not an expert on CRT or NTSC filters, but I’m pretty sure that the details in the background or other icons aren’t supposed to become invisible when a CRT shader is used. This and the previous picture are a bit ‘washed out’ compared to a proper CRT shader, yes, but it’s still demonstrably showing that the color representation is fairly warped, and the complex stacking of shaders means that it’s not easy to fix the parameters. It’s really not so much a matter of ‘taste’ when the issue is this severe.


#24

I’m assuming by ATI card you guys mean AMD? I didn’t think they made ATI cards anymore lol I do have an AMD, a horrible atrocious thing called an R9 390X that I wish I’d never ever EVER have bought…

As soon as I can find one for an even remotely decent price I will be getting an Nvidia GTX 1060 ITX card. Hopefully the rest of these will work at that point. lol


#25

AMD sorry, lol, i’ve always owned Nvidia, forgot they got bought out :stuck_out_tongue:

Yeah we had issues in the last pack with blurs, not sure a way around them although like Fiona said, switching to Vulcan might help. Of course one issue with that is in some of my settings I purposely selected older versions of shaders like crt-lottes or crt-hyllian because their properties are slightly different or they just get better performance. I guess we’ll come to that fork in the road as soon as everything is converted over.

Anyway i’ll see if I can go about fixing the gamma, if anything i’ll keep my settings the way I like for myself. Bear in mind there is 60-some presets in here so don’t expect it tomorrow, or if someone is willing to step up and is an expert at color correction and would be willing to help, that would be great too.

In the meantime keep playing around with the presets, there might be at least a few in there that suits your fancy.


#26

[QUOTE=Queen Fiona;44651] I’m not an expert on CRT or NTSC filters, but I’m pretty sure that the details in the background or other icons aren’t supposed to become invisible when a CRT shader is used. This and the previous picture are a bit ‘washed out’ compared to a proper CRT shader, yes, but it’s still demonstrably showing that the color representation is fairly warped, and the complex stacking of shaders means that it’s not easy to fix the parameters. It’s really not so much a matter of ‘taste’ when the issue is this severe.[/QUOTE] Pls try my modified Vintage Atari RF shader i posted earlier… i dont have CRT in home anymore, but i was playing some MD and SNES games few days ago on convention and i think that my version is really close to typical TV feel


#27

Hi solid12345 and thanks for answer.

islogged do you have an Nvidia or ATI card?

It’s neither one nor the other, i have an Intel HD Graphic Family Card (it’s a laptop) lol

FYI the setting in the screenshot you asked about is “diamondglass” in the arcade section.

Thanks!

I copied Horizontal.cgp File from “Analog Shader Pack version 3\Arcade monitors - Horizontal\Diamondglass\Horizontal.cgp” in my C:\RetroArch\shaders

I copied shaders_cg Directory from “Analog Shader Pack version 3\shaders_cg” in my C:\RetroArch\shaders

(I’m on Windows) I changed the shaders path in Horizontal.cgp like this:

shaders = “18” shader0 = “shaders_cg/Analog Shader Pack/COMPONENT/linearize.cg” filter_linear0 = “false” wrap_mode0 = “clamp_to_border” mipmap_input0 = “false” alias0 = “” float_framebuffer0 = “false” srgb_framebuffer0 = “true” scale_type_x0 = “source” scale_x0 = “1.000000” scale_type_y0 = “source” scale_y0 = “2.000000” shader1 = “shaders_cg/stock.cg” filter_linear1 = “true” wrap_mode1 = “clamp_to_border” mipmap_input1 = “false” alias1 = “” float_framebuffer1 = “false” srgb_framebuffer1 = “true” scale_type_x1 = “source” scale_x1 = “1.000000” scale_type_y1 = “source” scale_y1 = “1.000000” shader2 = “shaders_cg/blurs/blur12x12shared.cg” filter_linear2 = “true” wrap_mode2 = “clamp_to_border” mipmap_input2 = “false” alias2 = “” float_framebuffer2 = “false” srgb_framebuffer2 = “true” scale_type_x2 = “source” scale_x2 = “1.000000” scale_type_y2 = “source” scale_y2 = “1.000000” shader3 = “shaders_cg/halation/gaussian-vert.cg” filter_linear3 = “true” wrap_mode3 = “clamp_to_border” … …

When i load this shaders with M and N keys i got no change : http://imgur.com/a/1zfgH

  • Then what’s wrong?

  • Who can help me with this problem?

  • Thank You -


#28

You shouldn’t need to move anything around or edit any directories.

Just unzip the folder as-is wherever you like and don’t move anything around, the .cgp’s all point to the custom shaders_cg folder within the root directory already.

Go into either arcade, computer monitor, television etc. and find a setting and load it.

If this doesn’t work is there a way you can provide a log? do “any” of them work at all or just none work?


#29

The Zenith The standard vintage style TV

That makes me nostalgic. It looks exactly as I remember it was back in a day. Old crap. I’m glad I don’t have it see that nightmare anymore. I appreciate such a big effort by making the pack but for me it’s no use. I prefer not to have such experience nowadays playing old games like it was .


#30

[QUOTE=Great Dragon;44719]That makes me nostalgic. It looks exactly as I remember it was back in a day. Old crap. I’m glad I don’t have it see that nightmare anymore. I appreciate such a big effort by making the pack but for me it’s no use. I prefer not to have such experience nowadays playing old games like it was .[/QUOTE]

Well it’s not all vintage, there are 60 presets that range from a low quality tv look to a high-end Sony BVM.


#31

@solid12345

Just unzip the folder as-is wherever you like and don’t move anything around

Yeah it doesn’t work!

First: http://libretro.com/forums/showthread.php?t=4205

The hotkeys (M/N) will only switch between cg and cgp shaders in the root of the Video Shader Dir That’s mean not everywhere (mine is in standard /shaders of [ RetroArch Dir ])

Second: Your paths in *.cgp files use [ \ ], example ( shader0 = "…\shaders_cg\Ana… ) The include shaders which work in RetroArch use [ / ] path

Third: “Load Shader Preset” (in Gui) don’t work also as u can see here: https://vid.me/s8bh (video lag is due to the recorder, don’t got time to find a free good one)

do “any” of them work at all or just none work? All wich i test from ur pack doesn’t work! (i didn’t to test all)

If this doesn’t work is there a way you can provide a log?

How to do that?

  • Thanks -

#32

Hi I come back and tried to investigate the problem

It’s look like some shaders (cg files) inside the cgp files don’t work for me! And if one cg file (or more don’t work) inside the cgp file, the cgp preset-shader seems fully aborted.

A Video Capture of the issues: https://vid.me/P9pr

  • All the paths are corrects! (i checked and it’s just a copy of ur [shaders_cg Dir])
  • I tried with retroarch stable 1.3.4, stable 1.3.6 and lastest 1.3.6 and all same same!

No work!

- Then what’s this fu**ing problem?

  • Wich version and os u use? - How it’s possible that’s work for u and not for me? [B]
  • Thanks -[/B]

#33

Maybe try fresh RetroArch install… M and N shortcuts also stopped working for me and i must change presets manually…


#34

Maybe try fresh RetroArch install… M and N shortcuts also stopped working for me and i must change presets manually…

Hi, M/N work with the last build. It’s not the problem i expose. It’s not at all my problem here. http://libretro.com/forums/showthread.php?t=6577&page=4&p=44832&viewfull=1#post44832


#35

Thank you for the BVM shader. I would like to make the colours less vibrant, you can see with the 240p test suite how the colour bars appear like a solid block, without the shader they appear fine but I really want to know how to reduce the vibrant colours.


#36

In menu when you load and apply shader there are parametrs menu and you look for rgb settings or saturation


#37

I just want you to know that you are the reason I use Retroarch. Thanks for the hard work. 8)


#38

Seconding that. It’s an amazing effort. I can’t imagine how much time you’ve put in.

I agree that a lighter gamma version would be pleasant; some shaders are noticeably dark. You asked for help; would a mass find-and-replace across all the files (such as via Notepad++) make that easy to do in one go, or does each gamma-edited shader need to be carefully tweaked?

My other query is if there’s a way (or plan) to support rotated monitors, such as for TATE-mode shooters? That’s how I usually play; using the ASP’s “vertical” shaders on a horizontal screen sacrifices too much screen space and (in my limited testing) can result in a grainy image.


#39

[QUOTE=Alexandra;45087] I agree that a lighter gamma version would be pleasant; some shaders are noticeably dark. You asked for help; would a mass find-and-replace across all the files (such as via Notepad++) make that easy to do in one go, or does each gamma-edited shader need to be carefully tweaked?

My other query is if there’s a way (or plan) to support rotated monitors, such as for TATE-mode shooters? That’s how I usually play; using the ASP’s “vertical” shaders on a horizontal screen sacrifices too much screen space and (in my limited testing) can result in a grainy image.[/QUOTE]

I was thinking a solution might be to work with the 240p test suite and go in and gamma correct based off the gray bars in that. That being said maybe start with the obvious settings that should be more gamma neutral such as the higher-quality broadcast monitor and trinitron/wega TV simulations. I do think some settings like vintage TVs or arcades you can get away with a much brighter or much more contrasted picture for various reasons, it was common for arcade monitors to have their saturation and contrast turned up to make the image “pop” more, or older TVs I think having a picture that is “out of wack” so to say is natural as you are simulating not just an old TV but someone using it who didn’t know how to adjust their picture correctly.

Anyway what i’ll try and do is curate it better and go in and clean up things where it “makes sense” so to say.

As for TATE mode shooters, i’ll look into it more. I believe if you flip the image 90 degrees in your video settings it will rotate the masks and scanlines correctly with it, that is at least a good short term fix.


#40

[QUOTE=solid12345;45116]I was thinking a solution might be to work with the 240p test suite and go in and gamma correct based off the gray bars in that. That being said maybe start with the obvious settings that should be more gamma neutral such as the higher-quality broadcast monitor and trinitron/wega TV simulations. I do think some settings like vintage TVs or arcades you can get away with a much brighter or much more contrasted picture for various reasons, it was common for arcade monitors to have their saturation and contrast turned up to make the image “pop” more, or older TVs I think having a picture that is “out of wack” so to say is natural as you are simulating not just an old TV but someone using it who didn’t know how to adjust their picture correctly.

Anyway what i’ll try and do is curate it better and go in and clean up things where it “makes sense” so to say.

As for TATE mode shooters, i’ll look into it more. I believe if you flip the image 90 degrees in your video settings it will rotate the masks and scanlines correctly with it, that is at least a good short term fix.[/QUOTE]

I was just about to suggest the 240p test suite as a good benchmark! Using that should provide a more objective look at the various gamma settings. I think that color variation on some shaders is okay, as long as you’re working with a more objective basis like the test suite, or working with very specific games/systems/emulators which work well for the settings in question. I don’t think anyone’s asking for too much color correction on deliberately washed-out shaders, it’s more the high-quality TV and monitor shaders! (I’d also suggest using different versions of the test suite or different emulators to compensate for internal color representation differences.)

I also want to let you know that despite critiquing your work, I’m actually really glad to see you doing this. I like the concept and I’ve enjoyed previous versions in the past, so all I’m really commenting on is potential improvements. It seems like people who are more concerned about this are working with PS1 titles - while I noticed darker colors in, say, Super Metroid than seemed appropriate, it seems like there’s always going to be shaders which work better with different kinds of content than others.

It’d also be nice if we could identify which shaders are Radeon-unfriendly, so AMD users like myself don’t have to guess at what we can and can’t use. In any case, thank you for all your hard work!