Android Nightly discussion thread


#241

I tried the latest nightly October 15 on my Nvidia Shield Portable Kitkat, and there are still three mame cores available: Mame (2003), Mame (2014), and Mame without any year. The Mame core works fabulous, the Mame (2003) and Mame (2014) show different errors. One of them shows the “Open archive as folder” option, the other one just crashes after selecting it.

Since the Mame core works just fine and seems quite fast on my Shield, I am pretty happy with it actually. Thank you for adding that third Mame core at some point. I understand that the Mame (2003) core might still be helpful, because it will probably run some games faster. I am not sure what the use of the Mame (2014) core would be if the Mame core is up-to-date.

The Mame core also supports the analog controls on the Shield Portable very nicely now! Kudos to the Retroarch team for supporting this. I remember in earlier versions the analog sticks were supported, but always treated as digital inputs only.

I also quickly looked at the speed of the Retroarch Mame core against the program Mame4droid 0.139u1. Result: Retroarch is much faster, almost a factor 1.5 on some games I think. I tested this with heavy games such as Outrunners, etc. By the way Outrunners works great in Retroarch on the Shield Portable now, which is an amazing feat for a handheld console! It is such a great game, too!


#242

Having problems with choppy sound in the new mame core in my archos gamepad 2, is that normal? I am on the latest nightly, tested metal slug 3. and wild west cowboys


#243

Just tried mame4droid 0.139u1 and it runs most games fullspeed in the archos gamepad 2 much faster than the new mame retroarch core, I am curious which games are faster in the new core like rsn said.


#244

newer MAME = slower MAME, it has slowed down a lot as years have gone by


#245

My understanding there is that newer MAME does not necessarily mean slower as in performance MAME, it means more accurate emulation, some games on Neo Geo for instance actually have a slowdown in certain parts as normal gameplay.


#246

Some drivers have increased accuracy, and yeah slowdown can be a part of the original game, but it’s definitely gotten slower across the board. You can take a mature driver like CPS2 and load the same ROM across 2003, 2010 and 2014 and watch the framerate drop.

While accurate emulation is often slower than inaccurate emulation, increased accuracy doesn’t necessarily mean increased requirements. For example, the performance of higan’s bgba core improved in a bunch of games when byuu emulated prefetch.


#247

Well I have been testing only a few games that I regularly play on my Shield Portable, but the Sega games Outrunners, Power Drift etc that I tested are much faster on Retroarch than on Mame4droid. Now it might well be that Neo Geo games run slower on Retroarch. I use the Finalburn core for SNK, CPS1,2, and 3. I have always preferred final burn over Mame if possible. SF3 and Red Earth runs in fullspeed using Finalburn core on Retroarch on my Shield portable, which makes me very happy. If only the dpad on that device would not suck so much.


#248

is MAME 2003 going to work again with the nighly version?..MAME GIT runs fine in my SHIELD but is too slow for my ARCHOS GAMEPAD in this device I always run MAME 2003 but with the nighly it doesn’t works :frowning:

fMSX Core with the last nightly Failed to save state.


#249

[QUOTE=Quickgold;29633]is MAME 2003 going to work again with the nighly version?..MAME GIT runs fine in my SHIELD but is too slow for my ARCHOS GAMEPAD in this device I always run MAME 2003 but with the nighly it doesn’t works :frowning:

fMSX Core with the last nightly Failed to save state.[/QUOTE]

Having the same problem in nvdia shield tablet.


#250

Is there a changelog for the nightlies?


#251

Close: https://github.com/libretro/RetroArch/commits/master


#252

Great. Thanks!


#253

Hi, I make a fresh install with the last nightly and here I have the same issue like windows, RA detects the device but you can’t bind any button and it says keyboard no joypad, you can see User 1 device Index ARCHOS GAMEPAD (same thing happend to me with My OUYA, my Shield and my nexus 7 with a NES30 Bluetooth Gamepad) but nothing you can do for bind, autoconfig doesn’t works either :frowning:


#254

uh… autoconfig definitely works, I’m trying on my shield right now.


#255

Yeah I just reinstalled just to test and it’s working fine on my nexus 5 with a NES30 Pro.


#256

Oh man with this issue for you works (nice!) but since this afternoon I’m dealing with it and when you try to bind it says keyboard no joystick, the same thing happend to me with the windows port, the last nightly that works fine for me in all my devices it was 2015-10-10


#257

Hi, now all works fine again with my pads but like in Windows, I have to change Bind Mode from AUTO to RETROPAD (with AUTO try to bind to keyboard), autoconfig with the ARCHOS GAMEPAD doesn’t works because the Archos Gamepad autoconfig file is wrong, I did save a new file.


#258

I updated after a very long time and found that many shaders are missing…

(This was after I downloaded the newest using the update)


#259

Yes I no longer include shaders, just use the updater


#260

I used the updater to download the shaders and I many of them are missing…

only 2 shaders in the CRT folder, there used to be many of them fast, easy Etc…