Android Nightly discussion thread


#301

Not the UI itself,I specifically mentioned the touch controls,I mean the ones enabled via switching the “touch” profile to “everything” which works fine when pressing each of the buttons and even moving the analog stick part works smoothly. Though I guess you mean that RetroArch runs on a purely different engine than the use of Android’s UI engine,so thats what got something disabled.

Touch says “no” in 7zipper 2.0’s device info list,but that may be similar to the Play Store (requires touchscreen) compatibility filter. In an unrelated note,enabling the mouse support in RetroArch makes a white mouse pointer appear,but I can’t control it from the looks of it.

My first thought would be to blame Google since they are the ones who removed Shield Controller touchpad support in SATV and now they must have removed the emulated touch part that RetroArch uses for Retropad and the like.

I have been fine with playing the Classic Mario World 3 hack that was recently released,having the Retropad overlay disabled,but whenever an update is made,I will gladly test to see if it works again with that change.


#302

Hello, I wanted to ask what is the difference between: RetroArch.apk and RetroArch_debug.apk? If you go to nightlys there are always 2 APKs ago by date?


#303

The debug APK has some symbols used for debugging, that’s it


#304

I’m running RetroArch on my GPX XD. Had 1.3.2 installed and configured everything to my needs. Updated to 1.3.3 today and some things broke. Tried the latest (2016-03-21) nightly and still the same problem.

When opening a configuration (.cfg) file the core specified in that config file is not loaded anymore. Manually loading a core is not problem though.


#305

Yeah, question, why does the Android port of have a DeSmuME core if it’s this slow (<10 fps) on an nVidia Shield K1 Tablet? I honestly want to know. Using 1.3.2 official, no nightly build was being used, not trying to be rude, but just wondering.


#306

If it builds, we include it (typically), if not, not.


#307

So, the core is just part of the cores and will be released as is? Fair enough. I’ll just use DraStic or something in the mean time, sorry for asking a stupid question.


#308

Hello guys. Is the Mupen64plus core on Android supposed to be how it is? I tried every setting under the sun, from dynamic recompiler and glide64 to gln64 (like the regular Mupen64 for Android), high level emulation, and HW shared content. Still nothing but a black screen (or a crash). I tried the latest version on Google Play, the latest version on f-droid, and even the nightly from yesterday, and still no dice. This is my last resort. Can you guys please help me. I thank you for your time


#309

The core is broken atm, we will have to wait for a fix.


#310

Assuming it ever does…


#311

EDIT: Never mind; found the answer in one of my old posts -_-


#312

On Shield TV OTA 3.1 with the latest 4/18 nightly and touch still doesn’t work on the retropad overlay via Logitech K400 Plus trackpad let alone any touch in RA. Please try to fix this as other devices also have touch issues as well.


#313

Galaxy Note II - also waiting for a patch for the touch screen. Doesn’t work also mouse and S-pen

Fervi


#314

Is this the best place to suggest UI updates? There’s a few things I noticed that has stayed consistent release after release (I think I brought some up at one point in the past somewhere in the forums. Don’t remember). There were tested on an nvidia shield portable with both the latest nightly and the latest stable release:

  1. On options that allow you to cycle left/right through a list of values, hitting right at the end takes you back to the very first value. Hitting left though from there does not take you to the end of the list. Using Input > Max Users for example, pressing right at value 16 takes you back to 1, but pressing left at value 1 does not take you to value 16. I think this applies to every such option. Affects all menu drivers
  2. When moving inside to a sub menu and hitting back to return to the previous menu, your cursor usually stays at the last menu item selected. For example, if I enter the Video menu and make whatever changes I need to make there, and hit back to return to the main list of settings, the menu cursor remembers and starts off from the last item selected, which is Video. This doesn’t seem to be the case when entering the Input menu. Hitting back from there makes your cursor start back at the top (Driver). Affects all menu drivers
  3. On certain sub settings menu screens, hitting back after moving the menu cursor highlighting different sub items will make the menu start at a random spot at the beginning of the settings list and not at the spot where the highlighted menu item should be. It’s almost like scrolling through a sub menu also affects the parent menu’s scroll position. Affects only the glui driver I believe.
  4. This one isn’t so important but when using the touch screen to scroll and hitting the dpad while the scrolling animation is taking place, inertial scrolling does not stop. Only on the glui driver

Hopefully my explanations made sense.


#315

The latest nightly on Android (5-14) crashes when I try to open it. I can’t move the cursor properly using a controller after entering a game and going back to the menu. The cursor only goes from top to bottom when I try to move it after exiting a game. Sometimes, when re-entering a game, the controller doesn’t respond and I have to go to the menu for Retroarch to notice the controller. This was in the last couple builds, though I haven’t tested the latest build since it crashes.

I also have an issue where the core directory doesn’t save properly when I change it with the default profile. It does save when I load custom profiles, but I have to load them every time since the default profile automatically changes the directory back to the default, even after saving it.

Edit: I reinstalled the 5-14 nightly and it’s working now. I still have the same issues with the menu and core directory saving.


#316

You can’t change core directory on android. I’ll remove the setting I guess.


#317

[QUOTE=Radius;39014]You can’t change core directory on android. I’ll remove the setting I guess.[/QUOTE]

That’s not my experience. I was able to change the directory to elsewhere on internal memory, download cores to the changed directory, and load cores from the changed directory, just not keep it saved with the default profile. Please don’t delete the setting. I don’t want to root just to delete or use specific cores.

edit: Menu issue still not fixed as of the latest nightly. A bit disappointing that multiple issues were mentioned and the one that partially works gets the most attention.


#318

hello how to remove entierly the overlay screen on android?because my games are not fullscreen


#319

why the fucjed sreen are splited for all cores ?how to fix ?


#320

Seriously big cheers for the new GUI it looks amazing keep up the great work, btw speaking of cores could you consider add a frameskip option to mednafen PC-FX Core? it run very well on my Nvidia shield portable but sometimes the frames and music are choppy with 1 or 2 frame skip it could be perfect, please consider it.