Are there any CRT shadder the only thing it does is curved the screen?


#1

Hi! First, excuse me for my poor english :confused:

I’m looking for a CRT Shadder the only thing it does is curved the screen and not alter anything else, like ganma or the glitz, nothing.

Thx a lot :slight_smile:


#2

nobody help me? :frowning:


#3

Wow, are you still interested on this? :open_mouth: — OK, I have one, in fact it is just a mod of a existing one (from the libretro shaders) which I took and removed everything else. I don’t have it right now on hand but I will post it here once I get home tonight.


#4

Thx a lot @netux79!!!


#5

Actually I’d love to get a look at something like this as well. I want to see what happens when I run a screen curve with scalenx shader.

I’m having this idea to mix retro and enhanced to see where it will take me.


#6

Here’s the curvature code from crt-lottes on its own: http://hastebin.com/jerufaxana.avrasm


#7

[QUOTE=hunterk;35755]Here’s the curvature code from crt-lottes on its own: http://hastebin.com/jerufaxana.avrasm[/QUOTE]

you read my mind… that’s exactly the one I modded to get the curvature… I’m also sharing mine but it’s mostly the same thing guys and I will suggest go with hunterk’s as he is the shader master around here :wink:


#8

Thx!!! I love you!! xD


#9

It’s worth pointing out that just lifting the curvature code like that doesn’t do any sort of anti-aliasing so you get jaggies on horizontal/vertical edges.

The crt-pi shader (details here) can be configured to do curved screens without scanlines/gamma but with anti-aliasing - so curved lines look smoother.

Make the following changes to the crt-pi.glsl file:

//#define SCANLINES
#define CURVATURE
#define SHARPER
#define MASK_TYPE 0

Gamma will get disabled when the scanlines are disabled.

You’ll also want to change BLOOM_FACTOR to 1.0 or the screen will be too bright. You can alter the amount of curvature by changing CURVATURE_X and CURVATURE_Y.

dave j


#10

Ah, yeah, that’s a much better route. Just taking lottes’ warp code indeed causes heavy aliasing.


#11

I created a new account just to say thank you for this post. I’ve been hunting through newsgroups for two days trying to find some solution to edit the retroarch shader files to turn off scanlines, etc but maintain curvature. This was the solution I needed and it’s working across all of my different emulators. Thanks a bunch for posting this solution! :slight_smile: