ASUS Tinker Board Support


#21

"Atari Jaguar - Not enough juice. Very laggy"

  • Its core related and it can never be fixed as is missing arm dynarec so saying not enough juice doesn’t do justice to this excellent soc. :slight_smile: "N64 - A little choppy but some games playable"
  • U R Kidding right? I can play Zelda Ocarina of Time at 1080p with 60fps. Thanks for the feedback never the less appreciated.

#22

Nope. Not kidding about N64. A few games I tried were a little choppy and slow. One example would be Mario Kart 64. Tried with both emulators. You can feel the difference as you’re driving around. Smash Brothers as well but that was expected. Now granted I didn’t mess with any settings. I left everything with the default settings. I’m sure I can mess around with it to tweak it and get better results.

Don’t take my comment personal towards the work you put in. I appreciate the time and effort you put in to this. I’m simply relaying my experience with it so far.


#23

Signed up just to send a huge thanks for all your hard work. Think it’s too early to pick up a Tinker Board to use this build?

Thanks again. This is a huge development for retro game enthusiast everywhere.


#24

Can you re post a link for this? The current one doesn’t seem to be working.


#25

No need to repost it. It’s now in the builds to download.

http://le.builds.lakka.tv


#26

Thanks sorry I’m new and still figuring things out.


#27

Hi Lakka Team,

Thank you for the work getting this up and running on the Tinker Board! If you take donations, I’d be glad to contribute for your efforts.

One thing I’m curious about (just from a learning perspective) is how you got to a working build with what I assume is GPU-accelerated emulation. I’ve been working on this a bit (see my reference to my other thread above) and would love to take a look if you have a Github page or something.

I’m a software developer myself but I’m more on the embedded systems side of things, but I would love to start picking some of this up so that I can possibly contribute.


#28

The libretro team, including Lakka, takes donations a few different ways. Your contribution would be welcome: http://retroarch.com/index.php?page=donate


#29

hello all. i am having an issue with (for lack of a better term) blinking… my screen will go from the main screen and cut off to a black screen and back to the main screen… anyone else having these issues?


#30

ok after re burning image about 4 times. and re downloading the file… turns out i had 2 bad hdmi cables… (who would have thought). i have only tested N64 ps1 and all of the 16 bit games and under and N64 seems to be real…laggy. Anyone else experiencing this?


#31

N64 is super fast for me, even in HD


#32

N64 on the Tinker Board really just comes down to which game you’re trying to play and which emulator you’re using. I have experienced lag on quite a few games but I was also looking for it. There are still a good amount of games that run well on there.

Also, you’ll probably want to use Mupen64Plus. ParaLLEl does’t seem to do so well. If you’re using ParaLLEl, you should probably switch.


#33

i will try right now. I was playing mario kart 64. will follow up with results


#34

I am having an issue flashing the SD card with the image. can anyone assist me please?


#35

Can you provide some details as to what issues you’re having?

What operating system are you using?
What tool are you using to flash it?
What brand is the SD card?
What size is the card?
What speed is the card?
What error/problem are you seeing when you try to flash the image?

Without knowing anything the only thing I could say is to make sure you’re following the instruction on the lakka.tv site.

http://www.lakka.tv/get/

There’s no link on the site right now for the Asus Tinker Board so just use the image found here.

http://le.builds.lakka.tv/Rockchip.TinkerBoard.arm/Lakka-Rockchip.TinkerBoard.arm-2.1-rc5.img.gz

If you’re on windows just download that image file and start from here http://www.lakka.tv/get/windows/rpi2/install/


#36

I have unzipped the file with TAR, and used etcher to put the image onto a Toshiba 32GB micro SD card for my ATB but when I plug the power in to the ATB. nothing happens all I get is a red LED.

I was using raspian to in-tar the file.

I was using the image Lakka-Rockchip.TinkerBoard.arm-8.1.2.img.gz.


#37

Ok I just tried what you said

OS WIN10 x64 Etcher Toshiba 32GB Micro SD HC I am getting an error when it gets to 98% on etcher (see image)

Lakka-Etcher_Error


#38

its amazing what changing computers will do when you are trying to flask an SD card…its working thank you for your assistance!


#39

I have installed the image and it works…kinda. I know its to do with my tv('s)… ive tried 4 of them and on one, i can see the menu for 3 seconds and then my screen goes black for about 10 and it keeps doing this cycle. Also, it does it on the Tinker OS so i can confirm its my monitors. Once i sit there and struggle with the monitor that flickers to change the refresh rate and screen resolution , its fine til reboot… since it then defaults back to 1366x768 @59.81Hz for some reason which 3 out of 4 of my monitors wont even display anything and the 4th one flickers.

Is there a way to force a resolution and refresh rate by editing some file on the sd card via my PC since i cant even navigate menus? I’m used to raspberry pi where all the settings i need to mess with are in config.txt


#40

Hello everyone, I’m fairly new to Lakka and to this forum and would like some help please. I couldn’t find a way to start a new thread specifically for my problem. I have a tinker board with lakka installed and it’s works great. Most of my roms and systems I want work without problems. My problem is that whenever I try to play on my tv it doesn’t work. It shows the flower boot screen and then it says no signal but the tinker board is still on and working just not outputing to the tv. I know it’s on since I can still access it’s folders on the network from my Mac. TIA!