ASUS Tinker Board Support


#61

Download the 2.1.img.gz version from this list http://le.builds.lakka.tv/Rockchip.TinkerBoard.arm/


#62

How do we overclock the tinkerboard with lakka, what are the switch and where do we néed to add them?

Overclock cpu, gpu and ram all of it :slight_smile: I have good active cooling and very Nice power supply :slight_smile:

Thanks


#63

I can’t get wifi working with the latest 2.1 img. All I get with the GUI wifi settings is a single entry with an apostrophe. I’ve tried dropping back to the command line and when I use connmanctl to “enable wifi”, I get

Error wifi: Method "SetProperty" with signature "sv" on interface "net.connman.Technology" doesn't exist

Anyone else having this issue?


#64

I have the same problem as you, only wired connection works.


#65

Same to, maybe the WiFi driver is not working right yet


#66

Hey guys, don’t know if it happen to you but for me it happen everytime, i can replicate the problem.

If i use shutdown option in Lakka and then unplug the tinkerboard, the other time use it, i start it, it freeze after like 10 seconds in the lakka GUI, i cut the power, reboot it and it is ok.

If when i am done, i cut of the electricity directly on the board without using the shutdown option, it wont freeze the next time i use it.

Tinkerboard with Kingston gold 64 GB microSD and a xbox 360 controller. My PSU if a 3 amps


#67

Have you tried a different sd card? I can’t replicate that situation as mine starts and stops fine by the shutdown method. I just watch the activity lights when I shut down to make sure that the board is done with the sd card.

Also from what I read of the tinkerboard, there is no direct way to tell it to overclock as well as, in the documentation of the tinkerboard, it says that Asus will void the warranty if you overclock the board.


#68

No i did not try a different SD card but i also though that this would be the problem, i will try another one.

Overclocking, no problem even if i void my warranty, i have 4 tinkerboard i want to try it overclocked to sqeeze the most power out of it :slight_smile: hehehe, if anybody know of to do it in lakka i would defenetly do it.

I have good cooling system :slight_smile:

Thanks for the reply.


#69

Yes it does work fine with my Sandisk SD card, no probleme with the shutdown methode, so there must be an incompatibility somewhere, because the Kingston Gold SD work perfectly on a Raspberri pi.


#70

You are quite welcome. Glad it was just a minor thing. From what I have found on overclocking, it takes a beefy power supply and some kernel hacking and active cooling. the tinkerboard I have sits comfortably at 55-60 degrees C. and that is passive cooling with no overclock. but if you wish to dive in head first, at least make sure you are active cooling and have a 3 amp power supply. Here is a link to the information I found on the subject. but please note that this is based on Armbian and not LibreElec. https://tinkerboarding.co.uk/forum/archive/index.php/thread-654.html

On a different note, did anybody see that Asus is producing a new tinkerboard? It has the same processor, but there are small upgrades like how the HDMI port will be CEC compliant, the 3.5 mm jack will have some sort or sensing bit to it that will check the type of cabling plugged into it. there will be a 16 GB eMMC built into the board, some sort of power on header


#71

I will give it a try on overclocking, since it look like that file :rk3288-miniarm.dtb is the same file i can find on lakka, i might be able to interchange them :slight_smile:

I use active cooling with heatsink / thermal paste and fan, the 2GB LPDDR3 are heatsink cooled, and even a tiny custom made watercooled system that i also want to give it a try hehehe

3 amps psu

No didn’t eard of the new tinkerboard, very nice, i will buy it once it is available and give it a try.


#72

Building with today’s commits enables wifi support, and so far I have had no issues with controllers or cores.


#73

hey guys im looking at upgrading my retro pi 3 to a tinkerboard. i wanted sumthign with more power and from what i been researching is the tinkerboard blows the doors off the rasberry pi in n64 performance. wich is what i want. also its the same size so my nice retro NES case will fit the tinkerboard.

That being said hows the lakka support for tinkerboard? Hows it run? im mainly looking if it can run N64, PS One and Nintendo 3DS games good.


#74

I still get emails for this forum and i just had to log in for this one… DONT DO IT. Support is terrible. They never even respond to what ive asked at any point for one (look up above for my questions on the televisions… i have 1 out of 5 tvs capable of working with this… TinkerOS works on 4 of 5 and a Pi works on all of them… most of them 1080p. 20% = fail in my book)…

as for my experience with n64, well my tinkerboard with the latest image sits collecting dust and i might as well repurpose it at this point. i mean NO POINT in even posting any issues or anything… they wont be acknowledged let alone fixed. Maybe im being a bit harsh and i know its probably on my end but maybe someone would have been nice enough to atleast point me in the right direction and to this day, nobody has done so…

If youre going to upgrade, id say screw the tinkerboard and go to a cheap PC over this.


#75

I like my Tinker Board, but you do need to remember that it is a new board to Lakka and there are some rough edges in the last release.

Wireless does not work on that release and I had a real bad stuttering issue with PSX games.

If you take the time to compile the current source you will get working wireless and the stutter issue with PSX is gone. Not sure if that was due to an update in the OS or the emulator (PSX-ReARMed)

I am emulating Atari 2600, NES, SNES, GBA, GBC, GB, FB Alpha, Mame, Neo Geo (FB Alpha), N64, Sega Genesis, PSP, and PSX.

I have overlays (for scan lines and to frame the 4x3 picture or for the arcade machine bezel) and use the crt-pi shader.

My Tinker Board moves between an older Vizio, a new Sharp Roku TV, and a TCL Roku 4k tv. I have no issues with flickering.

For controllers I use Mayflash F300 fighting sticks, PS3 Six axis, idroid bluetooth controller, and some cheap PS3 clone controllers (they identify as shanwan ps3 when plugged into the USB, on bluetooth they say PS3)

The only issues I currently have is the shanwan controllers vibrate all the time when plugged into the USB it is a known issue and there is a fix coming. The other issue is a lockup in Nestopia and Snes 9x 2010 if I use my wii mote as a light gun (mouse) when I left click, I have not had time to actually trouble shoot it though.

With all that being said, if you have the money to do a NUC pc (or something similar) you generally will have a better experience due to the better cpu.


#76

Id like to give the latest a shot and im following: this http://www.lakka.tv/doc/Compiling-Lakka/… Tinkerboard is not on there… that being said what do i need to do in order to make a fresh tinkerboard image?


#77

I used Ubuntu 16.04 in VirtualBox (the image from armbian.com).

The build command is;

DISTRO=Lakka PROJECT=Rockchip DEVICE=TinkerBoard ARCH=arm make image

It took several hours to build on my little core i5 laptop.

alternatively if you have someplace for me to upload the image ( ~290 meg file) you can PM me the details and I can upload it.


#78

Thank you for the reply! Ive got an FX-8320 overclocked to 4.5GHz (my gaming rig) im going to try compiling on. Ive got virtualbox setup with the Ubuntu 16.04 image from Armbian. when running “DISTRO=Lakka PROJECT=Rockchip DEVICE=TinkerBoard ARCH=arm make image” it comes back and said FAILED. libjson-perl was not installed properly? Either way i run it the second time and it seems to be working


#79

Just tried the latest nightly; it doesn’t proceed beyond the flower screen. A quick check of the tty console revealed that Lakka was booting…but RetroArch was segfaulting on launch.

EDIT: “retroarch -v” reveals what seems like a lead:

[INFO] RetroArch 1.7.1 (Git 29a057ac98)
[INFO] === Build =======================================
Capabilities: NEON VFPv3 VFPv4 
Built: Mar 22 2018
[INFO] Version: 1.7.1
[INFO] Git: 29a057ac98
[INFO] =================================================
[INFO] Environ SET_PIXEL_FORMAT: RGB565.
[INFO] Redirecting save file to "/storage/savefiles/.srm".
[INFO] Redirecting savestate to "/storage/savestates/.state".
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 29970.03 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Video]: Starting threaded video driver ...
[WARN] [KMS]: Swap intervals > 1 currently not supported. Will use swap interval of 1.
[WARN] Failed to bind API (#2, version 0.0) on context driver "40ах".
[INFO] [GL]: Found GL context: null
[INFO] [GL]: Detecting screen resolution 320x240.
[INFO] [GL]: Vendor: (null), Renderer: (null).
[INFO] [GL]: Version: (null).
Segmentation fault (core dumped)

#80

Latest image fixed the segfault, but I’ve run into another issue; bilinear filtering is constantly enabled, and trying to turn it off has no effect.