Audio issue on Rpi 3 running lakka

So, I have a really stupid issue. I have lakka running on a raspberry pi 3. I’ve had issues with lakka and audio before on pc, but I just bought a pi, so I figured I’d try it out. So, the issue is that, no matter what I’ve tried, I cannot get audio to output through HDMI or even the 3.5mm jack. I’ve tried to aplay -l and aplay -L, but all I’ve got are sysdefault and default, both of which are CARD=ALSA, and both of which have the same information. Both of them are the “default device”. Sorry if I’m a bit noobish here, as I’m not new to linux, but I am new to raspberry pi. Configuring audio devices in this way has never really been a problem for me, until I got lakka. I’ve tried uncommenting numerous things, messing with the audio_device option in the config, and multiple other solutions. Not gonna lie, I think it might be an issue with the pi itself, as the only two devices listed in lakka are default devices (as mentioned earlier.) Thank you to anyone who can/will help. and thank you to all that take the time to read this. ~Nubbles

On RPi it should work out of the box, otherwise check this documentation.

So, turns out setting the audio device to hw:0,0 and uncommenting the hdmi_drive=2 line in my config did the trick. (I actually couldn’t figure out the uncommenting problem, because although I believed I had uncommented, in reality I had just removed one of the #'s from the line above.) XD

Consider my original post completely null.


Hi there, i know this is a old thread but I’m having the similar issue as nubbles. I’ve been stuck with this for almost months since March 2019 and I pause my project due to other works. I’m also a noob in Linux but over these few months learn quite fairbit by troubleshooting this issue. I hope some expert could save me.

Things that I’ve done:

  1. Download Lakka from the official site
  2. Flash it to MicroSd using etcher on windows 10.
  3. Configure my ps3 controller
  4. Using putty and ssh into the Raspi 3 model B(forgot to mention above)
  5. Edit and insert and uncommented the config.txt file using nano command as below
    • mount -o remount,rw /flash
    • nano /flash/config.txt Note: i read in most of the site they advice to change from the /boot but I can’t access the boot partition only /flash works for me

[insert] - hdmi_drive=2 [uncommented] - hdmi_force_hotplug=1 6. Edited the retro arch file using file explorer and navigate to \IPADDRESS\configfiles\retroarch.cfg

[Original] audio_device = “” [Edited] audio_device = “sysdefault:CARD=ALSA”

  1. Tried messing with the GUI audio driver and different combo, still doesn’t work.

Please do let me know where I’m wrong. Much appreciate and thanks in advance.

Did you make sure to stop the RetroArch process before editing the cfg file? If not, your changes will just get wiped out as soon as you exit.

Yes, I did stop the retroarch process by the following command: - Systemctl stop retroarch