Autoconfig controller controls both player one and two!


#1

[I am using retropie and posted this initially at retropie forums, but as I got no replies and I realized this was a retroarch specific problem i figured I’d try here]

Hello!

I am using controller autoconfig with two controllers of the same type. For one player it works fine but when I play any two-player game the player-one controller controls actions of both player one and two.

If I in retroarch enter the config and go to input, under player one and two the gamepad name is “Wrapped(ASUS Gamepad) (#1)” and “Wrapped(ASUS Gamepad) (#2)” respectively. - But gamepad one still controls both players.

My /dev/input contains four devices that are related to my gamepads event1,js1 and event3,js3 (note, event2 and js2 does not exist)

In my autoconfig file ( retroarch-joypads/Wrapped(ASUSGamepad).cfg ) the input_driver variable is set to “udev” but changing to “sdl” results in the same issue

What can I do to make retroarch allow me to use two controllers?


#2

Update [still not working]

I have tried renaming the event devices to be consecutive - but that did not help. I have tried making the second device report a different name - but the error persists.

Is there any input tool that I can start debugging this from? [preferably running in the terminal]

If I change “Input User 1 Binds” device to controller #2 - the second controller controls menu, player1 and player2.

[Off topic] When playing with control settings in retroarch there should be a “no-input” timer after changing user 1 device - as If I accidentaly change to N/A then I have no way of controlling retroarch and need to reboot.

–EDIT–

Just stopped using autoconfig and now the controllers behave as expected.


#3

Hello! I am plagued by this issue! Is the autoconfig a ra input config?


#4

A post was split to a new topic: No controller input - Linux