Beetle PSX HW: mask bit

I’ve read it’s one of the most difficult things to get right in a PS1 emu. Congratulations, devs! :smiley: Silent Hill looks good now. Any other games fixed by this?

Just checked and Xenogears’ ‘heat wave’ effect is still broken, guess it has nothing to do with mask bit.

Can you post a Github issue about that Xenogears issue along with a screenshot?

I am not a github member, is it ok to post it here? For example, the sequence at the beginning of the game, when Lahan is attacked and set on fire, there is this very cool effect, like extreme heat haze. Beetle PSX HW renders the scene incorrectly, like so:

It improves a bit at 1x IR but is still broken. Software shows it properly (both at 1x and 2x IR), like so:

And here is a savestate

Xenogears Lahan burns

1 Like


Decided to register on the forums since I’ve seen this twice now and . Here in this post (and the aforementioned github post) and here back in 2017:

Anyway, it’s apparently caused by Beetle PSX HW core options - “Renderer” being set to: hardware.

Setting said option to software, closing content (closing the game through retroarch), then re-running the game in software renderer mode fixes the issue but causes another bug by offsetting the SCE bios intro slightly to the left & up. Here’s a screenshot:

At least that’s how I figured it out. I tested all core options on & off one by one and that’s the only thing that affected it and made it go away. Also, might be an important factor: you can’t just switch the “Renderer” option to software then select “Reset/restart” in the command window or Quick Menu either. You have to close the game entirely then reload it again.

Just found this after starting Xenogears and noticing the same thing. Still broken not working in hw