Black screen on my Samsung TV


#1

I have an interesting problem and I was hoping someone could help.

Let me preface this issue by saying that I am currently running Lakka on an Asus Tinkerboard, and it is running quite well. Was just trying out some PSP Crisis Core, and N64 OOT which seemed to work well. I did my initial setup and install using a Toshiba LED monitor using HDMI.

Here is were it gets interesting. After getting all ROMS onto the SD card, I decided to move it to my older 40inch LCD Samsung. It would primarily be a black screen, and sometime flicker to a fuzzy screen, and then back to a black screen. I even got the menu to appear once. But since then I only get a black screen.

However, it works perfectly on my Toshiba LED monitor. I am using HDMI on my tinkerboard and HDMI inputs on both my devices. Both devices are 1920x1080. I have read about adding some various HDMI flags to the config.txt or boot.ini, but that does not seem to exist on the tinkerboard. Furthermore, I installed TinkerOS (Based on debian stretch) and the desktop and kodi appears fine on the 40inch Samsung.

Let me know if anyone has an ideas! I am fairly proficient with bash and a terminal so I can definitely try some stuff! Looking forward to getting this fixed.

NOTE

The more reading I am doing the more I want to try setting: hdmi_force_unplug=1 config_hdmi_boost=4

However, I cannot find this “config.txt” the people keep mentioning. Any ideas on where I can find it?


#2

That’s a Raspberry Pi thing, unfortunately.


#3

SO I think there is definitely something specific to my older Samsung TV. It seems the HDMI signal is a little weak. I forced the resolution to 1920x1080 in the retroarch.cfg and I got the menu again, but if you look closely there are small flickers, and screen tearing.

I was able to make this stable by forcing the resolution to 1280x720

systemctl stop retroarch
nano .config/retroarch/retroarch.cfg
video_fullscreen_x = “1280” 
video_fullscreen_y = “720”

When I rebooted, everything came back up, and Ocarina of time fired up immediately. However now i have a different issue. While SNES and NES games seem to scale up fill my TV. the N64 games seem to take up about 1/4 of the screen right in the middle. So tons of black space around the game. Is there an easy way to tell Mupen64 to scale games up to fill the screen as best as possible?

When running 1920x1080 on my small Toshiba display, this was not an issue.


#4

Are you using integer scaling (settings > video)? If so, disable that and it should stretch to fill vertically.


#5

Thanks for the suggestion! I tried disabling that, and the video stretched horizontally, but not vertically. So it looks quite odd.

I was able to keep interger scaling enabled, and changed the aspect ratio to 4:1 which fills the screen perfectly. This not ideal, as I will probably have to manually change this for the other systems, but it is, in fact working at the moment.

However, if anyone has any other suggestions I am definitely open!


#6

You can set it back to what you use everywhere else, then load the core+content and set it to whatever it needs to be, then save a core override and it will only apply those settings when that core is loaded.


#7

Ahhh that is helpful. I will do that.

Also, I think I found some of the options that I needed for the TinkerBoard. It loads the kernel at boot using: /flash/extlinux/extlinux.conf

I am still googling and reading extlinux.conf options. But so far I was able to tell the device to set the HDMI resolution to 720@60hz. Lakka would default back to 1920x1080 when exiting games and this seems to help with that. I will continue seeing what sort of options I can set here for the tinkerboard.

systemctl stop retroarch

mount -o remount, rw /flash

nano /flash/extlinux/extlinux.conf

Add video=1280x720@60

mount -o remount,ro /flash

shutdown -r now


#8

I know it’s an old post but was the only place I found someone with same issue. Thank you very much!