Blargg filters don't seem to work with SNES for me

I don’t know if I’m in the right place for this, but I figured shaders, filters, whatever. I thought I would try turning on the blargg snes filter in the video settings, and I get nothing. I’m using higan accuracy. Mega Drive/Genesis gets compressed into the left half of the screen, so I know it’s doing something somewhere. Does it just not work with SNES cores? That would be weird, considering the name.

None of the filters work for me either with the cores I tried (Dolphin, Mesen, Mupen64Plus-Next, bsnes-mercury, Higan, Flycast.) Tried gl, glcore and vulkan. The RA log says:

[INFO] [SoftFilter]: Found plug: EPX (epx).
[INFO] [SoftFilter]: Found plug: Darken (darken).
[INFO] [SoftFilter]: Found plug: 2xBR (2xbr).
[INFO] [SoftFilter]: Found plug: Super2xSaI (super2xsai).
[INFO] [SoftFilter]: Found plug: Scale2x (scale2x).
[INFO] [SoftFilter]: Found plug: LQ2x (lq2x).
[INFO] [SoftFilter]: Found plug: Phosphor2x (phosphor2x).
[INFO] [SoftFilter]: Found plug: SuperEagle (supereagle).
[INFO] [SoftFilter]: Found plug: Normal2x (normal2x).
[INFO] [SoftFilter]: Found plug: 2xSaI (2xsai).
[INFO] [SoftFilter]: Found plug: Blargg NTSC SNES (blargg_ntsc_snes).
[ERROR] Softfilter does not support input format.
[ERROR] [SoftFitler]: Failed to create softfilter graph...
[ERROR] [Video]: Failed to load filter.

This is on Linux with the latest nvidia binary driver.

Well, I got windows, so I don’t know what I’m doing wrong.

I believe this means the core outputs a color format that’s not compatible with the filter. I think it’s supposed to work with rgb565 while those put out xrgb888 or something like that.

Okay, so it seems to work with Snes9x, which is funny, because Snes9x has it’s own Blargg filters under options, which makes it kind of redundant, but hey, I ain’t complaining.

Using an NTSC shader is probably better anyway though. They’re faster than video filters. Try the various shader presets in the “ntsc” group.

1 Like