Cannot get ANY MAME roms to work with Lakka

I have a mame arcade machine down in my gameroom and I wanted to mess around with my RaspberryPi 4 with Lakka to see if I could get it to do what my arcade machine does.

Epic-est of epic fails.

My PC with Retroarch runs the roms just fine. On retroarch, I have ROMs the run under Arcade (MAME- Current) [0.220], Arcade (MAME- 2000) [0.37b5], Arcade (MAME 2003-Plus), Arcade (MAME 2010) [139u1], Arcade (MAME 2015), and Arcade (MAME 2016) [0.174].

On Lakka, it looks like I have two options for MAME Cores; MAME 2010 [139u1] and MAME 2003-Plus. But when I run those cores and search the directory for roms, do directory is created. When I loaded NES, SNES and N64 ROMs, the playlists were created with no problem. Any suggestions for getting Lakka to recognize and create playlists for MAME 2010 and MAME 2003-Plus ROMS? Thanks in advance.

David

I believe arcade ROMs need to be torrentzipped to scan properly. It’s usually easier/simpler to just use the manual scanner and feed it a DAT to get the “pretty” names.

As much as I hate to admit it, you advice is beyond my skill level. The first part (I think) I get; the ROMs are in a .zip format. The second part about the manual scanner and feeding it a DAT may as well be greek. Is that something I can do in Lakka or do I need to do it somewhere else? Thanks in advance.

David

Yeah, torrentzip is a special kind of zip that has a deterministic checksum. If you and I zip up the same file without it, there’s no way to ensure that our archives will have the same checksum, so our scanner–which uses checksums–won’t be able to match against the databases.

Yes, in the scanning menu, there’s an option to do a “manual” scan that bypasses the database/checksum checks, and on the manual scan submenu, there’s a place where you can provide a DAT file to provide the scanner with some extra info about the games it’s scanning. This is such a DAT here: https://raw.githubusercontent.com/libretro/libretro-database/master/metadat/mame/MAME.dat

Ok thanks. Is there a program I can use to re-zip folders to create a torretzipped archives? That sounds like it might be easier than adding the DAT files. If not, I can try the second route. Thanks very much for your suggestions. :slight_smile:

Dave

The DAT route is easier than it sounds. however, I think you can get torrentzip from here: https://sourceforge.net/projects/trrntzip/ and try a few files. If it works, you can probably script handling all of them at once.

Hello. I came across this same problem - I’m using Lakka on a Raspberry Pi 4, trying to scan MAME ROMs that are over on my NAS.

I am trying to go via the MAME.DAT route. I have copied the file from the link above onto the NAS in a location that the Pi can see it. I have set up the manual scan to point to the folder containing the ROM images (ZIPped), and I have attached the MAME.DAT file from the link above.

When I hit ‘Start Scan’, it says ‘Failed to load arcade DAT file. (Invalid format?)’

Does the file need to be in the same location as the ROMS? I have set up the manual scan for MAME-2003, as that is the set of ROMs I have.

Am I doing something wrong?

Did you fix the problem with the MAME ROMs, I have searched to find the ROMs but unsuccessfully, if you manage to fix your problem please share the solution.

It helps getting a actual rom set, that has the info on the mame version and rom set type. I get mine over at Archive. Sometimes I end up manual scanning arcade roms, if memory serves me right you can find the dat file on Github for MAME and other cores.

One of the sets I used “MAME_2010_full_nonmerged_romsets”, when getting roms online I find it safe practice to use a VPN and Mac changer combo.

See if this video helps, It’s for a Raspberry Pi 4 running Lakka OS, Though in the video there is no samba or ssh used because it is mounted directly to a pc running Linux Mint.

I see your link was removed. There is a reddit channel that discusses roms, or you can go watch the rom source video on Odysee

I don’t think I would be able to post a video showing rom sources so just go to the channel and view that video.

I was reading something about MAME ROMs and Lakka on Reddit but never understand what is the problem, never mind I will try reinstalling it again.

This document may be helpful: https://docs.libretro.com/guides/arcade-getting-started/

Solve the problem with MAME ROMs :slight_smile:

Why some of the MAME ROMs don’t show on the Emulator?