Compiling Lakka WTF


#1

Is there any way to figure out the proper OS to compile lakka.

I have tried Ubuntu, fedora, ubuntu studio, debian, Knoppix, linux mint, even visual studio for windows…

They all come up with vastly different errors that I have gotten by and then new errors.

The whole thing is a giant shit show.

What OS would be best to compile Lakka??

BTW there is serious errors in libjson-perl for like 3 different distros. Also some of the tar.gz files are not loading correctly have had to find the actual file and replace in the LibreELEC folder and try to recompile…

build essential are all set as well as upgrade update and “gcc” problems…

Can anyone point me in the direction of actually compiling the OS??

i.e. “start with SPECIFIC lubuntu version 1.00004” … or anything … honestly this is out of control


#2

Start here: http://www.lakka.tv/doc/Compiling-Lakka/


#3

thanks for response. Yes thats where the problems arise.

so first i go in “su” so i dont have to keep typing sudo… this puts me in “root”… whatevr i says goes…

so first you update/upgrade and distro-upgrade whatever linux version you are working with…

then install ‘git’ (apt-get git) …then clone the (https://github.com/libretro/Lakka-LibreELEC)…

very simple… pops up in a folder calle “Lakka-LibreELEC”… you “cd” into that folder and run the command …

DISTRO=Lakka PROJECT=Generic ARCH=x86_64 make image

because i want to compile the 64 bit pc version…

then its off to the races for a bit and then it usually quickly pops up with needed packages…

this is where it list all the stuff you need to build…

make and libjson-perl and like 10 other things and then i delete folder for lakka-librelec and start again…

clone https://github.com/libretro/Lakka-LibreELEC

cd into folder and rerun make…

DISTRO=Lakka PROJECT=Generic ARCH=x86_64 make image

the most recent error on linuxmint is

collect2: error: ld returned 1 exit status libtool: error relink ‘libblkid.la’ with above command before installing it

i guess i could load log files and etc but i got 3 people working around the clock trying to compile it once…

are we out of touch??

im loosing my mind (sorry for long post)


#4

I’m compiling it just fine in Ubuntu 18.04. It choked on libjson-perl, so I checked and I already had the latest version installed, so I just gave it the compile command again and now it’s been compiling for the last 5 mins.


#5

Im straight up over 2 hours in. To be fair its a core2duo that has gotten me the farthest with 4 gigs ram and 80 gig hard drive. Please let me know if it works out…

You should be at least an hour and a half behind.

If it works would you post a picture lol

I just want a tiny victory :laughing:


#6

Btw it also failed on like 3 OS’s on “Intltool.tar.gz” because the file that it downloaded was incorrect so i had to download the actuall file (from fossies.org) and put it in the “sources” folder


#7

Anything good on the compile…

I got the same list of errors on (linux mint and ubuntu)

first the libjson-perl (solved by installing newest ver)

then the (intltool-0.51.0.tar.gz error)… solved by downloading ----

https://fossies.org/linux/privat/intltool-0.51.0.tar.gz/

and placing in the sources/intltool folder

and FINALLY stuck on

                       ^

/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/libblkid/src/partitions/partitions.h:60:34: warning: size of ‘aix_pt_idinfo’ differ from the size of original declaration [-Wlto-type-mismatch] extern const struct blkid_idinfo aix_pt_idinfo; ^ /home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/libblkid/src/partitions/aix.c:47:27: note: ‘aix_pt_idinfo’ was previously declared here const struct blkid_idinfo aix_pt_idinfo = ^ collect2: error: ld returned 1 exit status

libtool: error: error: relink ‘libblkid.la’ with the above command before installing it

make[4]: *** [Makefile:4876: install-usrlib_execLTLIBRARIES] Error 1

make[4]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/.x86_64-libreelec-linux-gnu’

make[3]: *** [Makefile:11743: install-am] Error 2

make[3]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/.x86_64-libreelec-linux-gnu’

make[2]: *** [Makefile:11435: install-recursive] Error 1

make[2]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/.x86_64-libreelec-linux-gnu’

make[1]: *** [Makefile:11737: install] Error 2

make[1]: Leaving directory ‘/home/maniacs/Lakka-LibreELEC/build.Lakka-Generic.x86_64-2.2-devel/util-linux-2.29/.x86_64-libreelec-linux-gnu’

Makefile:29: recipe for target ‘image’ failed

make: *** [image] Error 2


#8

You haven’t included the entire make output. My guess is you need to compile libblkid with -fPIC.


#9

I got snagged on the libblkid thing, as well.


#10

I’ll be going back in on Monday. Up to my eyeballs in computer screens my brain is scrambled…

As always thanks for your speedy response hunterk


#11

Try this with Ubuntu


#12

I started with a fresh install of ubuntu long term (the newest) 18.04.2… Then update/upgrade. Then I installed all the packages you mentioned…

No libsonjperl error this time… Still got the initltool error i mentioned earlier. It looks like that file was compressed innacurately. I found a copy of it and placed it in sources/intltool folder…

ran just about the same until the libblkid.la error.

to be fair. After the error in compiling I recieved a error from ubuntu which read “system program problem detected”… i reported the problem.

I will have my guys try it again. Maybe in mint as Debian was just a poopshoot in general (no offense).

Thanks for the help


#14

Well, I pretty much gave you the answer to the most likely issue with libblkid but kinda hard to say as you still haven’t posted the entire output.


#15

Sorry I am not too familiar with this stuff was just messing around. If I understand it properly i have to “begin” to “log” what the computer is doing. Let it run its thing then stop the “log” process and i should have a file that explains what happens.

I tried to copy everything that happened in the terminal after i started building but it was like 90 thousand characters and would not let me post such long text.

I’m guessing i save a text file and upload it somewhere.

I will take a look and try to get you the output. I got two friends helping me out but they are not always around to hold my hand (as they are programners and i am not).

Thanks for reply I will try and get back to you asap


#16

https://drive.google.com/file/d/0Bw-PaSqXD4xKVW95Y3hqejlXVEFFTkVrQVBwdnlwTzBOejlN/view?usp=sharing

Ok I think this is what is needed?