Controller configuration issue: arcade -> gamepad


#1

Hi, I have Lakka (Lakka-RPi2.arm-2.1.img) running on my Raspberry Pi 3 and loving it a lot. I do keep running into an issue I cannot find the solution to.

I am using it inside an arcade cabinet with 6 buttons per player. I have configured the 6 buttons as they are supposed to be. This works perfectly fine with games which use 2 buttons (I only use FBA and MAME2003 emulators).

As soon as I run a game with 3 buttons or more, the software seems to remap these buttons entirely different. I believe it’s remapping to some kind of gamepad setup and I don’t know how to disable this. I can remap every game to their proper keys, but prefer not having to do this every time.

Anybody knows the solution to this issue please? :slight_smile:


#2

I think for FBA you can change the device type to ‘arcade’ either classic or modern and it will cooperate better.


#3

I am not seeing any options like that… should that be under settings-input-input bind p1-p1 device type? I only have classic modern and none as options there and it doesn’t change anything unfortunately :frowning:

Is it possible I messed up my retroarch.cfg somehow?


#4

I believe the classic/modern thing is what I was referring to. Maybe it used to have ‘arcade’ in the name…? who knows. Anyway, it’s meant for people using arcade sticks, so it should be keeping the buttons consistent.

I don’t think there’s anything you could have done to your config to make it move the buttons around, but an easy way to check is to move your config to another location and let RetroArch create a new one and see if the issue persists. If not, you can just move the old one right back.


#5

Okay thanks, I will check it out again tonight. Maybe I should set it to classic/modern and then reboot. I didn’t do that before. I will let you know :slight_smile:


#6

Reference mapping for 6 buttons arcade stick is

Y X L

B A R

‘classic’ is the way to go with this in fba


#7

Thanks, pretty sure I have it set up differently (can’t check right now), what’s the reference mapping for an actual control panel of an arcade cabinet? Usually 2 button games use B and A and they are buttons 1 and 2 starting from the top left.


#8

This is actually the one for 6 buttons arcade stick & control panel, there is no reason to differentiate between those two.

‘modern’ is for 8 buttons arcade stick & control panel.


#9

Thanks, I will map the buttons like you said and see what happens :slight_smile:


#10

Have tried a bit more with the classic and modern and changing the mapping around, but it keeps messing up the entire config. I’m not sure why it just can’t stop doing that, very annoying. Also tried deleting the config and creating it from scratch to no resolve. Perhaps I should try updating the image next as I am out of ideas…


#11

All you should need to do is go into settings > input and map your inputs like BarbuDreadMon’s diagram. After you get them mapped, never return to this menu.

From then on, only mess with the quick menu > controls menu. Once you set it to ‘classic’, you shouldn’t need to do anything else.


#12

There is no point asking for help if you don’t want to listen. Have fun not listening and remapping every game.