CRT Royale mask messing up colours

Hi, the overall colour of the screen changes depending on the triad size of this shader. Size 3.0 looks magenta and 4.0 green and anything in between scales badly. I realise the latest version of Kurozumi includes Grade so I can play around with this, but is there a better way?

I’ve tried on 2 IPS monitors and an OLED TV, Thanks

Trying to compensate for that is not going to end well. I would try changing the mask sample mode from 0 to 1 or vice versa and see it that helps you.

Try “crt-royale-intel” , set “Mask type” to 2 and adjust bloom excess until colors looks right (try not to go over 65)

@Wilch are you by any chance using crt royale on an lg cx? I have one and certain shaders had this magenta look for some reason. I fixed it by enabling chroma YCbcr 4:4:4. This only works at 60hz, couldn’t get it to work at 120hz. Not sure if this is your issue but anyway good to know i guess. Happy gaming!

@hunterk Reducing white-red tint improved the colours a little, but made the light colours sort of hazy. Is that what you mean? Changing sample mode helps with the colours, but the mask loses some of the punch that makes this such an authentic shader. It looks ok from a normal viewing distance I suppose.

@saeedalshaikhpygas that method does help somewhat when going for a sharp BVM style look with no visible mask.

@ledoeye It’s a C6, older model but similar. I know what you mean, I had to set input to PC mode to get 4:4:4.

Thanks for the help guys, I guess the sub-pixels don’t play well together. The worst is at triad 3.0 with the magenta tint to everything. 4.0 isn’t as bad and I like to simulate a low TVL CRT

Yes, the tinting is like looking through a pink window. That is, in that case, there’s no way to make it look right, only somewhat better.

The problem arises precisely because the mask is being made too small to display on the image.

I see. I figured it was due to the mask colours scaling up unevenly, hence the image changing between green and magenta depending on the triad size. Will this get better with higher res displays? I’m surprised I haven’t read more about this issue, especially considering the popularity of the shader

You should be able to get the mask to be pretty darned fine on a 4K display as long as RetroArch is running at 4K, as well. In fact, the problem is usually that the mask details are too small to see rather than too small to display. I would double-check that you’re not getting pushed down to 1080p somehow.

Normally, I would also suggest using a shader with a subpixel-aware mask (such as the updated crt-hyllian), but I’m not altogether sure how well that works with OLEDs, since their subpixel structure is straight-up bananas.

I was running at 2k on a 4k display as I’m using an igpu. I tried 4k and it does improve things slightly so that’s something to look forward to when gpus are affordable again. The resolution was correct in either case

One other thing which could be interacting is if your CX has the white led sub pixel. There might be a setting to turn off the white pixel.

That said it’s probably because of the resolution issue hunterk mentioned.

Also whenever you do this, additional blurring of the image happens after the signal gets to the panel to bring it to the 4k pixel array. This can definitely cause color issues when using masks. If you have a gpu which supports integer scaling this can sometimes help.

1 Like

It’s a C6, but I’ll look into the white LED sub pixel.

I’ve tried at 4k and it did improve the colours a little. I’m able to get a satisfactory image by playing around with mask sample mode and mask type, but I have to experiment every time the triad size is changed.

The resolution is definitely 4k as the screenshots I’m taking are the correct size. I’ll try disabling UI scaling anyway to see what that does, if anything

1 Like