CRTSwitchRes Lakka RPi 4 composite AV

Does anyone know what the state of CRTSwitchRes is on Lakka now? I have a RPi4B setup with composite video output via the AV minijack. There’s no option for CRTSwitchRes in the GUI but other threads on the forum seem to suggest it could be enabled via an ini file. However, I’m not sure those people were using the AV minijack. I’d rather not use RGB/VGA adapters because I want to preserve the composite artefacts and the port is right there. :nerd_face:

There’s no way to control the video output from the AV/composite jack via software beyond the couple of basic settings provided by the firmware (that is, NTSC vs PAL, 480i vs 240 doublestrike, etc.). This isn’t enough control to do switchres, which requires setting all values of the signal.

I see, that’s a shame. Thank you very much for letting me know. Since the AV port is not usable, what’s the best alternative? I’ve heard about hdmi to vga adapters and adapters that use the pins on the board but I don’t know any specifics so a point in the right direction would be helpful. Thanks again. :slight_smile:

I’ve used basic ones like this:

but if you’re going to a consumer TV, you’ll have to convert from VGA to something else, and the good versions of those tend to be fairly expensive.

You can try some of the gear from RetroRGB’s amazon list:

Specifically, the HDMI to YPbPr box. I had one of these at some point and I recall it worked with some devices but not others. I don’t remember whether my RPi3s were in the ‘working’ group or not.

That’s a good place to start. Thank you very much!

1 Like

@hunterk Alright, I finally got together the hardware and have an image on my crt via one of the micro-hdmi ports on the RPi4B. However, I’m now having a lot of trouble finding what settings I should change in the retroarch config file. Is there some documentation about this?

I’ve found and enabled the CRTSwitchRes settings in retroarch.cfg but my hdmi output in the menu and in games is always a horizontally squashed 480i. I did find Lakka’s documentation on CRT output, I tried adding the hdmi_timings line to my config.txt but it didn’t make any difference. Assuming I put it in the right place. The documentation doesn’t mention where that line should go. I’m now starting to wonder if my choice of adapter is the problem. I went for a cheap hdmi to composite adapter and maybe whatever conversion that’s doing is the problem. My CRT only has composite/RCA input so YPbPr would be no use to me. Not sure what to do now…

Many X-to-composite adapters indeed hard-convert everything to 480i (640 or 720 width, usually).

Sorry for the late reply and thank you very much for your advice. I’ll shop around for something better.