Cubox-i4Pro and Cubox-i4x4

I am currently looking for the most powerful ARM device I can buy to run Lakka on, unless there are better options it seems that the best ones out there are the Cubox-i4Pro and the Cubox-i4x4.

  • Can someone confirm that Lakka runs on both these 2 devices without any problems?
  • The i4x4 has 4 cores, will this offer any advantages when running emulaton?


Never mind, I just went ahead and ordered an i4x4. Hope all goes well.

Hi, we just tested it on the i4. If you get some issues, contact us.

It is working fine, just one tiny issue… if I shutdown the system, it just freezes. Is this normal?

Our shutdown entry is buggy. Add to that the context driver for vivante is never cleared. I guess those two bugs in one look like a freeze.

Hi, I just bought the Cubox-i4Pro, and it runs well with Lakka, except this shutdown issue.

Hi there. I have no sound in cubox-i4, whats your sound settings? Thanks!

For the solution about sound settings.

Hi. I have been running an older version of lakka on my hummingboard. Recently attempted to upgrade to latest version but failed via .update and network.

I reflashed sdcard and on first boot, all was working.

I noticed second partition on sd card was not using full space, so I used gparted to use full 14gb and that is when my troubles have started. Lakka now gets stuck at flower logo.

I have re-flashed sc card multiple times but same result, stuck on boot logo. After each re-flash, I do see installation text on first boot but after that nothing else.

I have tried reformatting sdcard and then reflashing but still no change.

Sorry for long message.

Kind regards.


edit: while I was typing this, error messages have displayed: failed to start journal services

Edit2: for what ever reason this morning when I booted up I was happy have it working. It seems every time when I access SD card in mint Linux Maya and copy my files over it messes up the card because when I try booting up i4pro I’m getting same journal service error.

What is console argument to view more details during bootup?

Edit3: I’m lucky to get lakka 2.1 to boot consistently. I’m not sure if using partition manager check feature in mint Linux is helping or not.

Do save states from previous versions lakka work with 2.1? Put in a few hours into lunar Sega CD after the upgrade and copying backups to card I can’t resume my game.

Is there a discord channel for lakka support?


I installed LAKKA on my cubox-i4pro and so far everything is pretty smooth … except for the sound. I can’t get any sound from the HDMI.

Does someone knows the magic recipe ?