Dolphin input?


#1

I have been having serious input issues with the Dolphin core and Wii games. These tend to fall into two categories:

  1. On some games, for example Super Mario Galaxy, it wants me to plug in the nunchuck to the WiiMote. Since I am not using a WiiMote or Nunchuck, this is physically impossible. Thankfully this is an emulator and we can tell it whatever we want! I tried switching the settings to say I have the WiiMote + Nunchuck, but that doesn’t change anything.

  2. Various popups on the title screens will say “press any button to continue” or “press B to continue”, etc… Even though I verify the mapping of the input is correct in the settings, the Dolphin emulator does not accept the button presses.

Input works just fine when its a game that supports the Gamecube controller. I am using a DS4 controller (which is auto configured perfectly by Lakka)

Has anyone had any better luck with this? Is there a trick to it? Must I actually use a Wii controller?


#2

Our core doesn’t support wiimotes currently. It’s better to think of it as a Gamecube emulator that plays a few Wii games.


#3

Its funny you should say that, because it barely runs Gamecube games (see my post on that) but has run every Wii game I have thrown at it (controller issues aside). Is someone working on this support?


#4

heh, weird. It’s usually Wii games that people can’t get working. Most Gamecube games should work fine.

It’s not really being actively worked on at the moment. Upstream Dolphin isn’t interested in working with us at all, so it’s kind of a doomed novelty at this point. We may try to re-port it and/or improve it at some point, but I personally think the effort is better spent on other projects that are actually interested in libretro support.


#5

To be fair I have only tried a few Wii games, but I have tried a dozen or so GC games and I don’t think I have had one success yet. (Success defined as actually getting past the menus into the game).

I am sorry to hear that. It does not seem like libretro (and by extension) Lakka is what I am looking for unfortunately. This process of maintaining a separate port/fork of an emulator and having to merge in/“re-port” upstream changes is always going to result in an outdated emulator, and thats no good for emulators that are in heavy development. This is off topic but does Lakka allow you to launch command-line apps (and therefor install stand-alone versions of the emulators) or is it strictly a libretro integration UI? I don’t really want to develop my own emulator front end, and Lakka is just so nice, that I hate to lose it.


#6

Lakka is specifically barebones linux + RetroArch. It lacks even basic OS functionality beyond that.

If you’re wanting to have a more feature-filled OS with the ability to launch other programs like Dolphin and/or Kodi, I would recommend a general purpose distro like Ubuntu. You can install RetroArch alongside any other programs you want to run, and there are launchers like EmulationStation and Attract Mode (I think?) that you can use to browse by boxart, etc. and then call whichever emulator you want to actually launch the games.


#7

Yeah, Lakka is just so nice though. Very minimal and just works great. I am not a fan of the RetroArch setup, and EmulationStation was dead last I checked. I haven’t looked in to Attract Mode.

I don’t need a more feature filled OS, I just want emulators that are updated more often, and it doesn’t seem that Lakka can provide that with certain emulators. I think I will still use Lakka on friend/family boxes that just want SNES and PS1 emulation, I have to find another solution for my emulation needs though.


#8

Could we maybe open a bounty to support wiimote and sensorbar properly?

Thanks.