DOSbox on ARM builds


#1

I’ve been trying to get Death Rally to work on DosBOX.

I managed to get it to work on my x64 computer having to alter the sound settings in the supplied SETUP.exe that comes with the binaries.

However, even after properly creating both the DOS.lpl and the rally.conf game won’t load.

Has anyone been able to make this work?

I haven’t been able to get a single DOSbox game to work on my RasPi3. Can anyone tell me one that works, and the configs used? So I can have a “test bed” to start with?


#2

Do you reproduce the issue with our nightly builds ?

Thank you.


#3

I was having some issues even loading the latest nightly, I’ll give it another try. Let ya know, thanks.


#4

I might have the same issue. Currently, I have the latest nightly build Lakka-RPi2.arm-2.1-devel-20180731011450-r28201-g1f26930 installed on my Raspberry Pi 3 B+.

I have the game Magic Carpet on the device, which I copied from my computer. It works on my computer using RetroArch.

I created this game.conf: [autoexec] @echo off mount d “/storage/roms/dos/magiccarpet” d: CARPET.EXE

I created this playlist: /storage/roms/dos/magiccarpet/game.conf Magic Carpet /tmp/cores/dosbox_libretro.so DETECT DETECT DOS.lpl

With this, the core seems to crash. Here is the system log from when I press the playlist entry to where Lakka crashes and I have to unplug/replug it: https://pastebin.com/hi2D4Zb6 At the end, it states “Illegal instruction (core dumped)”

Is it generally possible to run DOS on the Raspbi? Is there already a mistake I made? Where can I find that core dump for further investigation?


#5

Hi,

Did you try ?

coredumpctl list then coredumpctl info PID

Thank you.


#6

Hi gouchi

Thank you so much for responding.

It seems that I need further assistance. When I try to use coredumpctl, it says: -sh: coredumpctl: not found


#7

Is it working with systemd-coredumpctl ?


#8

This tool also seems to not be installed.

Lakka (official): devel-20180731011450-r28201-g1f26930 (RPi2.arm)
Lakka:~ # systemd-coredumpctl list
-sh: systemd-coredumpctl: not found

Edit: So I looked in the /bin directory and there is no tool named similar to coredump. I read that I could acquire it via apt or apt-get but those are not available or disabled on my Lakka installation.


#9

It seems we don’t ship coredumpctl tool.

Can you make a test with the canary build which has a more updated dosbox core ?

Thank you.


#10

Hi gouchi

I updated my installation by copying Lakka-RPi2.arm-2.1-devel-canary-f44b767.img.gz into the Lakka update folder and rebooting.

After that, I still get the same error message:
Illegal instruction (core dumped)


#11

Can you try my updated core?

git clone https://github.com/fr500/dosbox-svn.git
git checkout libretro
cd libretro
make target=arm

#12

Hi radius

I installed msys2, followed your instructions and now have a dosbox_svn_libretro.dll as a result.
When I try to open this core on Lakka, it says: Failed to open libretro core.

I read: http://www.lakka.tv/doc/Packaging-a-libretro-core-for-Lakka/ that cores need to be specially built for Lakka, but I am at a complete loss here. Can you provide me with instructions on how to proceed?


#13

Well, you built a windows core :stuck_out_tongue: Of course that won’t work

https://bot.libretro.com/nightly/linux/armv7-neon-hf/latest/dosbox_svn_libretro.so.zip


#14

I unzipped that dosbox_svn_libretro.so and put it in /storage/cores/ on my Lakka. I adjusted my playlist to use /storage/cores/dosbox_svn_libretro.so

Now instead of the illegal instruction, I get this error:
retroarch: symbol lookup error: /storage/cores/dosbox_svn_libretro.so: undefined symbol: SDL_GetTicks


#15

yeah I still haven’t figured how to bake in SDL properly, sorry, it’s gonna take a while. I don’t think LAKKA has SDL1.2 and SDL_net


#16

Alright, thanks for helping.
So, for Dosbox to work on the raspbi, Lakka would need to have SDL and Dosbox would need to use that SDL?

But at the moment, Dosbox does not work on the Raspbi. Or generally ARM builds? Or generally Lakka?

I would like to stay updated when this changes. Where would I need to look / subscribe to?


#17

dosbox (non-svn) should work just fine. Only my newer core requires SDL.


#18

I see.

So the dosbox core I had on my raspbi from the beginning should work.
But it doesn’t and I can’t get a coredump to investigate.

What can I do?


#19

Welcome to my world…

and by that I mean, it’s frustrating to ask for help , and the first answer is try on the latest nightly, well that doesn’t teach me how to troubleshoot, and even if you did to add to the fustration, as you mentioned retzioka, you can’t use apt-get or anything to install additional packages and tools you’d otherwise use to troubleshoot. as you’ve noticed he says run this, and then follows up with, oh we don’t package that with the release…

Now for a final release I can sort of see that but on devel releases why are these tools not available for us? Like really we don’t even have the tools the devs ask us to use to help them. They say they want to help, yet don’t give us the tools needed to help them help us… what a catch 22