Duimon - HSM Mega Bezel Graphics and Presets - Feedback and Updates

I updated the shader file by copy and paste and git pull, but it still does the same thing.

Edit: I am thinking that if the fix was on your end that you may have forgotten to upload the files. I only say that because I have the most recent HSM files as well.

1 Like

Newest version of the shader and a fresh Git install of my repo.

No parameter changes.

Did you delete the old “bezel” folder first?

I opened the shader file then copied and pasted the code. I am just going to download the master zip file.

Edit: With the bezel folder, I always download the zip file and overwrite everything.

1 Like

You need to update your Mega Bezel version. Not my presets.

I have made no changes to my preset since I created it. The only fix was in the Mega Bezel.

This may not be the best strategy. In the least, if files have been renamed you will have extra files, at worst you cannot reliably troubleshoot issues.

Edit: I repeated my experiment, deleted and reinstalled the Mega Bezel, and did a fresh Git install of my package. It works for me.


I deleted HSM and redownloaded it the problem still persists.

1 Like

I don’t know what to tell you. Maybe it is a pull error.

You can try renaming your Duimon_Mega_Bezel folder and doing a fresh Git clone.

Edit: I did create the 270 version later so the files may have been renamed.

You should have these presets in the Lynx folder.


If I switch to desktop mode I get this.

I don’t know why it would matter but I may have not added the widescreen parameters. I will do some digging.

What is your screen resolution?

My screen resolution is 1920 x 1080

1 Like

OK try another pull.

I was using Integer scale when I designed this, for use as a template for my Batocera decorations. It was throwing things off.

I don’t know if this will solve your issue, but it solved the desktop mode issues.

Along the way I found a couple of errors in the WonderSwan verticals and fixed them.

I also included the widescreen parameters in the Lynx Vertical presets. They are left out of the horizontal until I create off screen graphics.


I am actually doing a fresh download of the files right now. The fixes will hopefully be in there, if not I will do a seperate git pull. I am doing this because I deleted the files before you posted about desktop mode. Just have to wait and see if everything is fixed. Desktop mode fixed for you should be fixed for me.


I strongly recommend you to set up Github Desktop and pull Mega Bezel from there as it will make the entire process a lot more easy and convenient :wink:

You will able to see all the changes which is great :star_struck:


Working on it now. I am on Linux that is why I haven’t installed it before. I was able to find something on github that has a script file to download it for Linux.

Plus, I should mention that for some reason git clone is slower than ssh. I don’t know if it’s that way for everyone.


I may actually include a release for download once everything is in a more complete state. I just don’t know how GitHub will react to multiple 1GB+ releases. (There is a hard limit on repo size.)

It would be cool to have a dedicated utility for downloading and updating community projects. I may contact EmuMovies and get some info on their utility.


are you using the same core for Lynx ? there are 2 : beetle Lynx core and Handy core. :wink: if i remember well, you don’t have same result at start…

I am using the Handy Core. Finally downloaded the files and it works now.


I am glad. That was a tough one to figure out. :upside_down_face:


Bugs found and fixed through some weird path.

1 Like

I was able to get Github Desktop for future updates.