FB Alpha / Neo on RPi Zero

I’m trying to get my FB Alpha (Split set) to work with Lakka on RPi Zero but I’m getting nowhere. This romset is working fine with Lakka running the FB Neo core on my PC. But Lakka on Pi Zero only has FBA 2012. I downloaded from the nightly and manually put FB Neo .so and.info into the cores directory, but can’t get any rom to run.

Can someone please help? What do I need to do to play some Metal Slug?

Interestingly, the Lakka docs state that “FBA is set as the default emulator for Arcade in Lakka. We ship the version” but yet out of the box install the exact romset isn’t working.

What do I have to do to make make this work. Anyone?

RPi Zero is very weak and probably can’t get good speeds with FBNeo, so it only ships with the older, faster, less-accurate 2012 snapshot. Load that core in RetroArch and it should show the core’s version number in the lower-left corner of the screen. You’ll need ROMs from that set.

The ones you have might work, just make sure you have the neogeo.zip file alongside the Metal Slug ROM. If that doesn’t work, you’ll probably need to get the right ROMs for the core.

Thank you for the information. Your hint about neogeo.zip helped.

I deleted the FBNeo core and .info from /cores. Tried again by selecting FBA 2012 core and loaded mslug directly, no go. Put another neogeo.zip and tried again, this worked! So perhaps it was a bios mismatch.

Now the thing that’s eluding me is that the FBA 2012 playlist isn’t generated. When I was trying to use FBNeo, even though it didn’t work, but scanning would generate a playlist.

What am I doing wrong, is there a fix?

You are doing nothing wrong. Unfortunately, RetroArch does not have a database for FBA 2012, which is required for creating a playlist specifically for its romset.

Apart from manually creating the playlist, I suppose the best you can do is keep FB Neo to create the playlist but instead choose FBA 2012 as the core. This will be hit-and-miss compatibility-wise, though.

Another option would be the same as above with an old-ish MAME core (2010 perhaps).

1 Like

Thank you. I did just that. Put FB Neo .so and .info back into the /cores folder and it did generate a partial list. At least I have something to work with, manually editing the playlist is gonna be a nightmare.

That being said, yeah the RPi Zero is struggling with arcade, fps is low but somewhat playable but the sound is so choppy.

Are there any settings and configuration tweaks that will help to speed things up?

Nope, in FBNeo there are 2 settings that can help some systems (cyclone & underclocking the emulated cpu), but it doesn’t seem anyone backported them to fbalpha2012. Imho, while some specific combination of game/core might be playable, your main arcade emu on rpi0 should be mame2000, the rpi0 is just way too weak to use anything else globally.

1 Like

Thank you, that helps a lot. Is MAME2000 included in the RPi 0/1 Lakka distribution, or do I have to manually add this core? Also, MAME 2000 needs the 0.37b5 romset right?

Edit. Sorry. Answering my own questions, MAME2000 uses 0.37b5 romset, and included in Lakka RPi 1/0 package, what’s not built in is MAME2003.

Now my question is, where do I find the MAME2003 *.so and *.info to put into /cores? Not in the buildbot.

The core file is here:


The info file should be included in Lakka. If not, it is here:


1 Like

Fantastic! Thanks for the links. Very much appreciated, thank you!

Edit. Not sure what to do, MAME2003 core is not loading on my RPi Zero.

Post a log of the crash and we can take a look.

Maybe that’s why it’s not included in lakka ? Did you try the MAME2003 core (preferably the “plus” version) ? I think it’s still less demanding than FBNeo & FBAlpha2012.

I found some time and got back to pursue this. So yeah, I was completely mixed up. MAME2000 is built into the rpi 0 Lakka build. It works with the old 0.37b5 romset.

What’s not working is adding cores to storage/cores. The ones I tried have the *.info file already in the build.

For example, I tried to add MAME2003+ (extracted the *.so from http://raw.libretro.com/nightly/linux/armhf/latest/mame2003_plus_libretro.so.zip), it shows up in select cores, but once selected Retroarch just restarts.

Why did it not work?