FB Alpha roms, unable to get any thumbnails working

I’ve successfully installed Lakka with the FB Alpha rom set and everything seems to be working fine, except I can’t get the thumbnails to display. I downloaded thumbnails using the Online Updater to get FB Alpha thumbnails. After successful download I got a directory “/storage/thumbnails/FB Alpha”. Still I got no thumbnails. I’ve googled around and found something about directory names having to match. I believe the actual name of the playlist is named “FB Alpha - Arcade Games”, so I also tried renaming the directory inside thumbnails to match that. Still no success. I’ve also verified that the lpl file also has the name “FB Alpha - Arcade Games.lpl” inside it (after the crc). I’ve also noticed a slight discrepancy in the naming scheme which may be related. E.g. a game can be named “Some Name / Some Subtitle”, while the artwork file would have a matching name like “Some Name _ Some Subtitle” (replacing slash with underscore). I just took a short stab at getting rid of the slash in the name in the lpl file to match the artwork file but did not notice any improvements. Any ideas?

thumbnails location should be “< whatever_thumbnails_folder_you_set >\FB Alpha - Arcade Games”, then inside this folder is Named_Boxarts, Named_Snaps, Named_Titles

the filename should be whatever it is labeled in the playlist, so if label is Art of Fighting 2 / Ryuuko no Ken 2 (NGH-056) then the filename should be: Art of Fighting 2 _ Ryuuko no Ken 2 (NGH-056).png

only rename the the character to “_” if its any of the following: &
/ ? : `` <

|

use markwkidd’s playlist buddy if your using windows-these makes life easier

1 Like

Thanks, this is pretty much exactly how things are, after I renamed “FB Alpha” to “FB Alpha - Arcade Games” inside thumbnails. FWIW, only Named_Boxarts exists, but even when I select boxarts in setup it does not work. No art appears. Annoying!

I went through everything again with a little more patience. With renaming as described and some patience, box arts did indeed start appearing, although very slowly. I guess some process in the background is working through the huge list of games. Thanks.

it can even be “< whatever_thumbnails_folder_you_set ><whatever_the_name_of_your_lpl_file>” if your are using custom playlusts

so if you have custom playlist named FBAlpha - CPS2.lpl, then your folder name should be “< whatever_thumbnails_folder_you_set >\ FBAlpha - CPS2”

1 Like

Hi, I’m having same situation or kind of…

My retroarch show ok NES and FBA thumbs but mame didn’t work. I spent a lot of time searching about this issue but nothing found and it’s driving me crazy…

Also tried to debug retroarch binary but no error given :thinking:

so here is a sample of my Mame playlist:

  "path": "/storage/roms/Romset_0.78_lr-mame2003/005.zip",
  "label": "005",
  "core_path": "/tmp/cores/mame2003_plus_libretro.so",
  "core_name": "mame2003_plus",
  "crc32": "2bbd8481|crc",
  "db_name": "MAME 2003-Plus.lpl"
},
{
  "path": "/storage/roms/Romset_0.78_lr-mame2003/yard.zip",
  "label": "10 Yard Fight (Japan)",
  "core_path": "/tmp/cores/mame2003_plus_libretro.so",
  "core_name": "mame2003_plus",
  "crc32": "5f1653d3|crc",
  "db_name": "MAME 2003-Plus.lpl"
},
{
  "path": "/storage/roms/Romset_0.78_lr-mame2003/vsyard2.zip",
  "label": "10 Yard Fight (Vs. version Japan, set 2)",
  "core_path": "/tmp/cores/mame2003_plus_libretro.so",
  "core_name": "mame2003_plus",
  "crc32": "87fc935d|crc",

here is thumbnail dir:

Lakka:~/thumbnails # ls -l
total 4
drwxr-x---    5 root     root          1024 Aug  2 15:27 DOOM
drwxr-x---    5 root     root          1024 Aug  2 20:31 FB Alpha - Arcade Games
drwxr-x---    5 root     root          1024 Aug  3 01:50 MAME 2003-Plus
drwxr-x---    5 root     root          1024 Aug  2 15:27 Nintendo - Nintendo Entertainment System
Lakka:~/thumbnails # ls MAME\ 2003-Plus/Named_Snaps/ -l |more
total 76261
-rw-r--r--    1 root     root         12075 Jan 18  2019 '88 Games.png
-rw-r--r--    1 root     root          4172 Jan 18  2019 '99_ The Last War (alternate).png
-rw-r--r--    1 root     root          3306 Jan 18  2019 '99_ The Last War.png
-rw-r--r--    1 root     root          2094 Jan 18  2019 005.png
-rw-r--r--    1 root     root          3717 Jan 18  2019 10 Yard Fight (Japan).png
-rw-r--r--    1 root     root          3549 Jan 18  2019 10 Yard Fight (Vs. version Japan, set 2).png
-rw-r--r--    1 root     root          3591 Jan 18  2019 10 Yard Fight (Vs. version World, 11-05-84).png
-rw-r--r--    1 root     root         32288 Jan 18  2019 1941 - Counter Attack (Japan).png
-rw-r--r--    1 root     root         27630 Jan 18  2019 1941 - Counter Attack (World).png

I think I tried everything possible, naming, permissions, different thumbnails versions…

As a note, online update didn’t work either…

Anyone had some advice?

Thanks to all.

Hi @jducifuentes.

All MAME thumbnails go in thumbnails/MAME (no year).

This is a change that was implemented a while ago and is not documented anywhere, as far as I can tell. I was fortunate to get this tip on Discord.

1 Like

My f*** godness, you are the best! Confirmed it’s working. Developers please write about in documentation.

Thanks!!