FBNeo + Linux-ARM

Hi, Has anyone else used RA+FinalBurn Neo on Linux ARM? I used a FBNeo build made earlier Jan 2024 that has some different behavior compared to Windows+FBNeo, where the screen flickers kind of crazy on Linux when running Space Fury (arcade). I’m not sure if it’s related, but I think that game was designed to run at 40hz instead of 60. I’ve tried tweaking some settings, but have not been unable to get rid of the flickering under Linux-arm. I believe there are also some audio aberrations as well (static like) due to whatever is causing the problem. Under Windows, it just worked from the start without issues. Let me know if anyone has recommendations on how to resolve that, thank you! (Note, I’ve already tried the fbneo force 60hz option among other settings)

I haven’t tried including additional bios files that might come into play, but I don’t think I have those on Windows either.

The effect of this core option is disabled for any game supposed to run below 50Hz (i suppose i should mention it in its description).

Your issue is indeed most likely due to some kind of incompatibility between your setup and 40Hz content.

Thanks for the response. It’s weird though,

  • Using RA+Mame2003 or Mame2003-plus, the video issues don’t exists for the same game on the same hardware.
  • I’m using the same monitors with my Windows setup, and I don’t experience the issues there with FBNeo, but of course there are different video drivers in play from the Linux system, (although both ‘gl’ in RA), but still, since it works from RA+Mame2003-plus, something is off somewhere.

What’s the resolution used on your linux-arm device to run this in FBNeo ? The game is rendered with a 800x600 resolution with default settings, and 1440x1080 when the “Hires Mode” dipswitch is enabled.

Those are arbitrary resolutions, there is no real concept of “resolution” in vector games, for example mame2003-plus is using 400x300 as default resolution.

If your device is somehow downscaling this from 800x600 to something lower, it’ll probably lead to gfx issues where pixels flicker.

Thank you,

I see with RA-Mame2003, the runtime log reports
Set video mode: 3072x2304

But with RA-FBNeo, it reports
Set video mode: 2400x1800

These appear to be similar ratios, but I think between win-fbneo and linux-fbneo, the dipswitches are the same except for frameskip threshold and type, neither currently defined on linux, but on Windows are “33” and type is “disabled”.

When running spacfury under Win-FBNeo, it reports
Set video size to: 1440x1080. yet another similar ratio.

To clarify, i’m asking the display resolution currently used by your linux OS, i’m not asking about retroarch resolution.

I don’t know what this Set video mode: 2400x1800 message actually corresponds to, it doesn’t seem to be a message generated by retroarch. If that’s really your display resolution, is your screen even a 4k screen ?

No, I’m not using 4K, just standard 2K, but when it spits out 3072x2304 (and the end display is fine in that case), I’m not using that resolution either, but the ratio matches at 4:3. I don’t have differences in configurations with those different cores, that’s just some of the direct log output from running retroarch. It could be that the bastardized retroarch executable used by MyArcade is the main culprit in this scenario.

Well, you are on your own then, i neither can nor want to provide support for commercial products, in the first place, considering an older FBNeo build was originally included on your device, it means it is breaking our non-commercial license.