[Fixed][Lakka RPi4] Issue setting up controller Key from Krom Gaming

Hi everyone! I’m new using Lakka in a RPi4, but I’m veteran using RA on Windows. I flashed the image Lakka-RPi2.RPi4.arm-2.3.2.img and I can use my keyboard. Then I have a generic wired Xbox360 controller that works great on RA for Windows10 using Xinput, but in Lakka using udev it doesnt work. After plug-in in RPi4 it shows a notification that says i connected a SHANWAN PS3 controller, then another notification says it has been disconnected and follows another notification that a Xbox360 controller has been connected. So, I went to input setting and i tried to bind all keys but it doesnt detect any button.

What I’ve tried is to save the autoconfig and tried to modified some keys using another autoconfig that works in Windows10, but changing de input driver (udev) and the device name, but it doesnt work. So i went to the website of the controller and I saw that the controller has compatibility with PS3 and PC. I’ve tried to update the controller autoconfig but it doesnt work.


So I think there is a kind of obstacle between the xbox mode and the PS3 mode of the controller.

May you try to make a test with nightly build ?

Thank you.

Hi gouchi! I have been tried this image Lakka-RPi4.arm-nightly-20210429-4685525 with the same result. First, a SHANWAN PS3 disconnected notification, then connected a Xbox 360 controller has been . But it doesn’t respond to bind all keys. So, I went to system information and I saw there was a Input named Xbox Controller.

It is so weird, but maybe the problem is that this controller has compatibility to PS3 and PC, then udev has a problem to detect one of this protocols.

You did try to switch from dinput and xinput and vice versa ?

May you try to provide some log with he output of lsusb ?

Thank you.

There is udev, linuxraw, parport and hid input drivers gouchi. I dont know if there is Xinput and Dinput in Linux. Anyway, linuxraw and hid doesnt work.

Here is the log from lsusb command:

Lakka:~ # lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 045e:028e Microsoft Corp. Xbox360 Controller
Bus 001 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And here it is the dmesg: https://pastebin.com/cKkTDrmt

This lines are interesting:

[    9.479525] usb 1-1.3: new full-speed USB device number 4 using xhci_hcd
[    9.573885] usb 1-1.3: New USB device found, idVendor=2563, idProduct=0575, bcdDevice= 2.00
[    9.573896] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    9.573904] usb 1-1.3: Product: PS3/PC Gamepad
[    9.573911] usb 1-1.3: Manufacturer: SHANWAN
[    9.584228] input: SHANWAN PS3/PC Gamepad as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:2563:0575.0003/input/input3
[    9.584496] hid-generic 0003:2563:0575.0003: input,hidraw2: USB HID v1.10 Gamepad [SHANWAN PS3/PC Gamepad] on usb-0000:01:00.0-1.3/input0
[    9.783059] usb 1-1.3: USB disconnect, device number 4
[   10.248869] usb 1-1.3: new full-speed USB device number 5 using xhci_hcd
[   10.355394] usb 1-1.3: New USB device found, idVendor=045e, idProduct=028e, bcdDevice= 1.10
[   10.355412] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   10.355426] usb 1-1.3: Product: Controller
[   10.355439] usb 1-1.3: Manufacturer: SHANWAN
[   10.371637] input: Microsoft X-Box 360 pad as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input4

Thank you for the log.

Did you try to switch to dinput to see if it is works ? It seems there is an issue to recognize it as xinput controller.

To change between modes press and hold the Home button for about 5 seconds.
X-input: LED2 lights up.
Direct-input: LED1 lights up.


1 Like

Ooooh! It works @gouchi ! I could not figure out that the manual of the controller manufacturer was the key.

Thank you very much!

1 Like

Nice, I am glad it is working now.