FreeIntv: the new Mattel Intellivision core (with video demonstration)


#1

About FreeIntv

@recompile recently published a new Mattel Intellivision emulator written as a libretro core. It’s called FreeIntv and is now available for a growing list of platforms via the libretro buildbot.

BIOS files

FreeIntv requires two Intellivision BIOS files to be placed in the libretro ‘system’ folder:

  • Executive ROM: exec.bin MD5 Hash: 62e761035cb657903761800f4437b8af
  • Graphics ROM: grom.bin MD5 Hash: 0cd5946c6473e42e8e4c2137785e427f

Please note that BIOS filenames are case-sensitive

Controls

One of FreeIntv’s key innovations is a virtual control system that makes it possible to access a a representation of the Intellivision numeric control pad by using the shoulder buttons on joypads from the SNES era and upward.

FreeIntv can also use PS1-style analog joysticks to represent the Intellivison’s original 16-way joystick.

My inspiration for posting a new thread is that @KMFDManic created the video linked above which demonstrates this FreeIntv virtual control scheme with a variety of classic Intellivision titles. Especially while the docs are still in development, this video plus the FreeIntv README are the best way to dive in.

Free Intellivison ROMs

Open source, Creative Commons, and other permissive licenses:

Modern freeware ROMs:

RetroArch Playlist Scanner

As of January 27, 2018 the RetroArch playlist scanner can identify and add TOSEC-validated Intellivision ROMs to a Mattel - Intellivision playlist. Download the latest 1) Assets, 2) Core Info Files, and 3) Databases from the RetroArch Online Updater to enjoy Intellivision playlist scanning.


#2

Thanks for this.

Is there anything the core needs to work? Like a bios or something? It crashes when i try to load a rom.

Edit: Saw the readme file, it needs the bios files.


#3

Just closes out when I try loading a rom. I downloaded fresh core and info file, Retroarch says both files are detected and correct and roms have .int extension.


#4

That sounds like it may be an issue with the Intellivision BIOS files. Do you have a set in your libretro system directory? I just added more information to the OP about this.


#5

Yeah they are in the system folder and RA says they are good in the information window, I will look for some others and see if they are better.
Edit:
It appears that my grom.bin is incorrect and but my exec.bin is fine. Just have to find a good grom.bin now.


#6

I believe that MESS uses the same Intellivision BIOS files as FreeIntv, so you may have luck if you find an Intellivision BIOS pack for the MESS emulator.


#7

Not having any luck finding the grom.bin file with the MD5 0cd5946c6473e42e8e4c2137785e427f but ill keep looking since I am pretty much certain that is the issue.
I am using WinMD5Free to check them, any idea if that is crap or not ? It says my exec.bin is the correct MD5 though.

Edit:
LOL and of course the very next search and test got me the correct file and everything is working perfectly.


#8

You can use the ROMs from the commercially available “Intellivision Lives!” CD-ROM, dump the ROMs from an Intellivision console, or attempt to find the ROMs on the 'net somewhere. These are the same ROMs used by the MESS emulator, usually found as “intv.zip”.

Source: http://iso.nl.netbsd.org/pub/pub/os/Linux/distr/salix/sbo/14.1/games/jzintv/

This advice should be enough to help you find the right grom.bin.


#9

I found the file, just took some persistent digging :slight_smile:


#10

I also get a crash when trying to use this core. Bios files is OK, and this is the output of verbose, updated everything (core,info files & database) this morning.


#11

I don’t see anything obviously wrong, although to be honest this core doesn’t yet produce much in the way of logs.

What source have you used for your Intellivision ROMs? Is it TOSEC or GoodINT, etc? It might be helpful to try ROMs from a different set if you haven’t already.


#12

I can’t make this work properly.

The games load but there are no controls, the options don’t even show any buttons to configure and i’m getting tons of graphical glitches in some games like Frogger.

Using the latest nightly and latest core in the buildbot.


#13

I tried both and both failed


#14

Android build any time soon?


#15

We’re working on it, but there is no ETA. If you have any expertise compiling for Android, please feel free to drop in on the conversation here: https://github.com/libretro/libretro-super/issues/710


#16

an android core would be so nice thanks


#17

Good news! FreeIntv is now being built for android, but no one who has been compiling it can test an android core.

If someone reading this thread is able to download the core, info files, and databases, it would be great to hear how it is working (or not working!)


#18

I tried it on my tablet (android 5.1) and it fails on both the TOSEC and Goodsets


#19

Are you able to post logs?

If so, I have have added a little bit more logging to FreeIntv around the BIOS load and cartridge load functions. You will need to re-download the core, but it might help narrow down which part of the process is causing the crash.


#20

Get this with each one I try. :
Intelllicart format not detected. Determining load method via database.

Here is a full log: https://pastebin.com/yBC28cLR

I’ve updated the info files and the database. Tried it with both the goodset and tosec