FreeIntv: the new Mattel Intellivision core (with video demonstration)


#21

Thank you very much for the log.

Are there any other video drivers available on your system to try?

edit: I have added yet more logging. If you don’t have another video driver to try, could you download the updated version of the core and try again any time at least an hour after this post?


#22

Got tired of waiting for the buildbot, so built it myself :smiley:

Here is a log that I got using the newest build:

https://pastebin.com/m5yQuK7v

still no luck


#23

You’ve been very patient, thank you. Based on our work together I think that you are experiencing a “bad opcode” error.

If you can recompile from source again, your error log will now include the opcode that has caused FreeIntv to halt. If you have time to post one more log I am hoping that the new details will be enough of a trail for @recompile or someone else to pinpoint the problem.

Could you also mention whether you are able to try running with a different video driver?


#24

Here is the latest log: https://pastebin.com/LRvBVC7S

I tried but it runs badly


#25

Could you clarify whether it’s the RetroArch interface that runs badly, or whether it’s FreeIntv?


#26

I’ve tried changing from the default to sdl2 and the performance on my pc is a bit slower than the default setting. Where I can run PSX games on mednafen_psx, I can’t using the sdl2 driver.


#27

Thank you for all your cooperation. Among other things it has helped add some useful diagnostic information to the logs.

The same ROM runs fine in RetroArch via FreeIntv on my Windows 7 x64 system so there is hope that someone else will be able to identify the specific problem and help get it working for your environment.


#28

Looking at the pastebin, it’s dying really early – before the first frame. My first thought was that there was an error in the database, but it’s using the correct load method for that rom (which works on retroarch on my pi3). Of course, that load method is also the default/fallback method as its the most common, so there isn’t a guarantee that it’s actually matching the entry for that game in the db.

If I had to guess (and I must) I’d say that you had a bad rom or that the rom isn’t being loaded from disk for some reason. As you’ve tried that rom from multiple sources, I doubt it’s a bad rom. There’s the odd possibility that you just renamed a .zip to .int, but I can’t imagine anyone doing that. If we could log the fingerprint, then we could eliminate one or both of those possibilities.


#29

I doubt it’s a bad rom, as mame loads it fine

I’ve tried a few games from quite a few places and all fail :confused:


#30

<I’ve added links to free Intellivison ROMs to the OP>

edit: @recompile I think there is a good chance that 4-Tris will end up as part of the built-in RetroArch free content downloader in the near future (mostly because of its GPL license).

After thinking some more about @te_lanus 's situation, would it make sense to have a standard testing & troubleshooting ROM for users?

If you agree, I’d suggest that 4-Tris could be a good recommendation as the first ROM for people to try when they’re setting up FreeIntv or troubleshooting it. It’s easy to get already, and soon it may even be available automatically from within the RetroArch interface, at least for RA and Lakka users.


#31

here is a log using the 4-Tris: https://pastebin.com/HTSU0DNp


#32

This is how graphics look in some games for me. Looks like color clash or something. This game (Frog Bog) looks fine in MESS.

I also don’t have any controls or control options to configure buttons.

Anyone else have these problems?


#33

@ GemaH This is what Frog Bog looks like in retroarch on my pi3:

It looks like the background card colors are off on yours. I can’t yet explain why they’d be different. I looked over stic.c, and I can’t find even the potential for the particular differences displayed. This may take some time to puzzle out.

At least the sprite colors are correct.

@markwkidd That’s a really great idea. Interestingly, 4-tris doesn’t seems to render the block colors properly (at least for me) so it might offer a clue as to why GamaH is having trouble.


#34

I found a problem with colored squares mode that kept 4-Tris from working properly. There’s a pull request to review.

It shouldn’t have any impact on the mysterious Frog Bog problem @GemaH is experiencing, unfortunately. It also still works correctly for me after the patch.

@te_lanus Looking at the log, it detected 4-Tris as being an intellicart rom. The version I have is not, and uses the .int extension. Your rom also uses the .int extension. Intellicart roms typically use the .rom extension. If your rom isn’t an intellicart rom, that makes me think that the rom isn’t actually being loaded. The buffer in to which the rom is initially loaded isn’t initialized, so it start out filled with whatever was in memory. I’m guessing that, by wild coincidence, the left-overs happened to have the magic number that indicates an intellicart rom.

It looks like some additional logging was added to cart.c, so it’s worth checking out. It should tell us everything we’d need to know.


#35

In addition to the fix and additional logging for FreeIntv mentioned by @recompile, the RetroArch playlist scanner now supports TOSEC-validated Intellivision ROM collections.

Download fresh Core Info files and Databases, then point them to a folder of TOSEC ROMs for streamlined loading.


#36

Downloaded everything new, and a new log (or 2)

https://pastebin.com/AYej1WU3 - 4-tris (downloaded from the link in the OP
https://pastebin.com/xEFkMffW - TOSEC (newly downloaded)


#37

Thanks for that. I’ve now fixed an incredibly stupid bug related to loading intellicart roms. The spatula city 4-Tris intellicart rom works now, at least for me.

Unfortunately, the TOSEC AD&D - Treasure of Tarmin bin file also works just fine for me.

I have no idea what to investigate next.


#38

I’m cursed :sob::sob::rofl:

https://pastebin.com/uL8wCZV4


#39

Downloaded the latest version of the core today. This is how the game looks like now:

I tried downloading the rom from a few different sources. I also tried bios files from different sources as well. Game looks broken like this. It also affects other games as well, not just that.

I can’t explain the lack of controls either. The core is supposed to have pre-configured controls but not only they don’t work, i get no configuration options to change them. The only options that appear are “load preset” and things like that. I get no options to change individual buttons.

I tested both Windows 7 64bit and Windows 10. Same bugs.


#40

@GemaH could you post a log? Also, have you tried using a different RetroArch video driver?

edit: I ask this question because, for example, many cores don’t work right on my Windows x64 system with the gl video driver even though the RA menu works perfectly with that video driver.