FreeIntv: the new Mattel Intellivision core (with video demonstration)


#41

All driver options have the same results.

I need to search a bit around and see how i can post a log.

Any idea why i also don’t see any buttons on the control options?

Edit: Whenever i bring up the RA menu and close it, i can briefly see the correct graphics for a split second before it goes all buggy again.


#42

Just tried testing on Android Samsung S7

Retroarch build date 26/12/17 so a bit outdated.

Unable to load core from menu option

On loading content RA crashes. (Using known good bios and roms)

Downloaded core from Online Updater about an hour ago.

Sorry I am no good with logs


#43

I set up msys2 and tried out a Windows 10 64 build. I was able to reproduce the problem you described and correct it. I haven’t tried it on Windows 7.

@te_lanus Good news, 4-Tris also crashed for me on Windows. Even better: the change made to fix GemaH’s problem seems to have fixed that problem as well. With any luck, it will also work for you.

For anyone who looked at it: I don’t particularly care for the fix, but I’ll take it.


#44

me give up: https://pastebin.com/LahEGqQj


#45

Frog Bog graphics bug is fixed now, thanks!

There are a few more issues i found. In Frogger, the graphics also seem to not be correct, when the various lanes move you can see them flicker/disappear or change shape. This shouldn’t happen normally.

Also, i have trouble starting some games. Frogger (for instance) doesn’t move no matter what buttons i press. In Dracula i can choose players and difficulty but i can’t start the game. In Donkey Kong, i can select players and difficulty but when the game starts, i can’t move. This lack of control seems to be a theme with many games where you choose number of players and difficulty.


#46

There isn’t universal agreement on what controller should be “player one”. Pressing select will swap the left and right controllers. That should let you move in games like Donkey Kong.

For Dracula, after selecting the number of players and difficulty, you’ll press ‘8’ to start.


#47

As of today, RetroArch and Lakka users can download a new ‘assets’ pack from the online updater and enjoy playlist and ROM icons for Intellivision in the XMB menu by @baxysquare. Thanks!


#48

Could you describe your PC RetroArch environment?

It might be useful to know your processor, video card, operating system, and anything else in terms of hardware & OS that you think could be relevant.

Maybe one of us has something similar to test with.

Are your operating system and video drivers fully up to date?


#49

I’m running Ubuntu mate 16.04 (fully up-to-date) with a GT240 (with the latest NVidia drivers for it) on this with 3gb memory

Retroarch is installed from the testing ppa


#50

I have only compiled RetroArch from source in Ubuntu other than some idle playing with Flatpack. Once I get some time I’ll install it via the testing PPA and see if I can reproduce this crash – maybe in some way it’s related to the PPA. I don’t know much about that technology and it seems unlikely, but maybe that’s the wildcard.

(Hopefully not) speaking of crashes, Twinaphex just let me switch on libretro buildbot support for FreeIntv for Playstation Vita. I have no way to test that platform, but it would be great to hear about the experience of anyone who does give it a try.


#51

I recently (this morning) compiled retroarch on my machine, and it still fails to load. :frowning:


#52

The buildbot is now compiling FreeIntv for the PlayStation 3.

I also added libretro builbot recipes for FreeIntv on the PSP, Nintendo 3DS, Wii, and WiiU. I’m not sure how to tell if those cores are building or not, but they may be! :sunny:


#53

The FreeIntv github repository has a new, long-term github repository address: https://github.com/libretro/FreeIntv

That’s right, it’s moved the rest of the way into the libretro ecosystem. It feels so official!

Nothing specific is changing by virtue of the repository’s location, but it’s one small step towards long-term availability of the core.

Thanks again @recompile Woot!


#54

Thanks @markwkidd – This project wouldn’t be where it is without your efforts.


#55

Tried it this morning, and it’s getting almost there. RA starts by showing the window then the notification of my controller gets shown then it crashes. It no longer crashes on loading, but when it should be starting to show something.


#56

It might be worth another go, I just uploaded a lot of small fixes that might help.


#57

nope, still loads to where the video should kick in and then it crashes


#58

This week in FreeIntv:

  • Twinaphex contributed build fixes for PS Vita and Emscripten
  • There is one more new line of logging during the ROM loading/identification process to help with future debugging.
  • I discovered how to that the libretro buildbot logs are accessible via the libretro discord server so I can troubleshoot some build problems
  • FreeIntv is definitely building for Nintendo 3DS, Gamecube, Wii, and WiiU
  • FreeIntv is not building for the PSP as well as older Windows and xbox MSVC compilers, which I suspected but now that I have logs I can attempt to figure out the secrets of MSVC makefiles.

If anyone else wants to take a look at the failing PSP build, here is the link:

<retrobot> freeintv: [status: fail] [recipes/playstation/psp] LOG: http://p.0bl.net/158438

Here are links the MSVC build logs:

<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2010-x64_seh-generic] LOG: http://p.0bl.net/158457
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2010-x86_dw2-generic] LOG: http://p.0bl.net/158459
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2017-desktop-x64_seh-generic] LOG: http://p.0bl.net/158461
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2017-desktop-x86_dw2-generic] LOG: http://p.0bl.net/158462
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2017-uwp-x64_seh-generic] LOG: http://p.0bl.net/158464
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2017-uwp-x86_dw2-generic] LOG: http://p.0bl.net/158465
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2017-uwp-arm-generic] LOG: http://p.0bl.net/158466
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2003-x86_dw2-generic] LOG: http://p.0bl.net/158468
<retrobot> freeintv: [status: fail] [recipes/windows/cores-windows-msvc2005-x86_dw2-generic] LOG: http://p.0bl.net/158469

#59

Hi

Did a test tonight and this is the crashlog I hath: https://pastebin.com/PWUSUdJp

and this one is done with gdb (not much, since it crashes in such a way that a backtrace is impossible) https://pastebin.com/anMKDzby


#60

Have tried testing this on 3 x Android Devices now and crashes. Same behaviour & problem on all. Samsung Tab s3 , Samsung S8 & minix u9-h. Retroarch build is 1.7.1 FreeIntv core was obtained from online updater. Once installed it can be seen as a selectable core but is unable to load. RA crashes after an intellivision rom is selected to load. Using good Bios & Roms.