Hatari Resolution Issue? [Help]

Hi, I’m trying to use Hatari with Lakka, and I can’t figure out how to play my game.

I put the tos.img in the right place, and the core starts, but the game (wizard’s crown) does not load. It just shows me a white screen. If I go to the core options, there is only one option to change the “internal resolution”, and the lowest it goes is 640x480. I’m using an old CGA/RGB monitor that can’t go that high, it only can do native Atari ST resolution (or as high as around 320x240). I want to run things in native 320x200. I found the hatari website that shows options, but I can’t make sense out what I should do. They mention that Hatari uses “zooming” to increase the resolution, and that you can set the --zoom option to “1” to enable 320x200. https://hatari.tuxfamily.org/doc/manual.html

Can anyone help me figure out how to get things running?


You’ll need to get RetroArch outputting to the monitor first using the desired/required resolution/modeline. Once that’s working, the core should automatically use that same res.

Thanks for the reply. The monitor is working aces with every other core I’m throwing at it.

It looks like this is the res you probably want:

Do you have the high resolution option enabled? if so, disable it.

I guess my problem is that I don’t know where all the options are. My option file for hatari only has one option “internal resolution” I think the solution is to make a cfg file somewhere, but I don’t know where. There is a guide that doesn’t quite seem to fit. It suggests a hitari.cfg file. I can find a “hitari.opt” file in my system.

Usually, all of your core options will reside in retroarch-core-options.cfg. If you can load any games with it, you can just change the options from the quick menu.

Yeah, that’s how I found the “internal resolution” option. It “loads” a game, but it just displays a solid white screen. With hitari on a PC, it never loads a game directly, but drops you into the Atari desktop and you launch the game from it’s folder location. I suspect the white screen I see is an improperly loaded Atari desktop. I can then go into the options menu where there is only the one option. (two if you count “save game option file”)

Hmm, I just pulled a new copy of the hatari core and it loaded up Wizard’s Crown just fine. It showed the white screen with the Atari logo and then the atari desktop where I could launch the game. There’s a “high resolution - needs restart” option that once disabled produced a low-res image (as determined by it not triggering crt-geom’s interlacing simulation).

If you want to add the core option to your retroarch-core-options.cfg manually, it’s this:

hatari_video_hires = "false"

Good news. I managed to get the Atari desktop to show. I think manually adding the hires to false did the trick. Thanks for that!

Unfortunately, I’m still having trouble with the disk drives. I tried to follow the guide that tells you to put that path for disk drives in hatari.cfg file, but it doesn’t seem to work. How are you defining the path for your drives?


I didn’t have to do anything like that. I just loaded the game from the menu and it automatically opened it up and everything.

Thanks. I was able to get to the game launch screen in wizard’s crown, but I get stuck when I try to “Play game.” I tells you to insert “Your Data Disk” into drive A, and then it says there’s nothing there. This is after the copy protection check. :frowning:

Edit: I figured out the disk change thing. You have to press Y on the controller in-game, and it will take you to the Hatari overlay menu. The disk control setup menu is there. Damn, that took a long time!

Thanks for you help, hunter

1 Like

I want to update this. I haven’t been able to get Wizard’s Crown working at all. I’ve had plenty of other games work fine, but there’s some inherent issue with games that require a formatted disk. Any attempt to format a disk from inside TOS fails. (this is different from using Hatari to create a disk image as the games use their own method for formatting).

If you really got this specific game running, like actually playing, please tell me how you did it because I can’t figure it out.


hey, no, i never actually got past the disk swapping stuff.

Thanks for the confirmation.

I think there’s got to be a trick to it. I read a bit about the formatting issue and game disks. I think it’s something that later ST units can do, like the STE or the Falcon maybe. There might be a combo that gets things running.

1 Like

Update on Lakka 2.3.2

After the update, the Hatari option file now defaults to hi-resolution. Turning off hi-res makes the Hatari menu inaccessible. (when you attempt to access it, the screen blinks briefly) Running with hi-res on a 240p screen results in a squished up mess.