How can i create a new topic? :/


#101

you would have to update/downgrade libretro common.


#102

@hunterk I want to build that revision because I made a cheat sheet with CheatEngine for a game running on that revision some months ago, and now none of them works anymore, I tried changing many settings trying to bring them back to a previous state, but cheats still don’t work so I believe the problem could be related to the different core revision. I’ll try to build a different core and see if it works.

@radius how can I do that? Downloading it from another revision?

EDIT: I tried building the last revision but I get the same errors. Actually, I get multiple errors that I try to fix by changing the source code. First error: https://pastebin.com/J26kCEgL which I try to fix by removing the “WINAPI_FAMILY_PARTITION(WINAPI_PARTITION_APP)” check since I know my intel supports SSEx instructions. Second error(which is thrown when I fix the first one, and which I fix the same way as the first one): https://pastebin.com/GcBadccW Third error(which is thrown when I fix the previous ones): https://pastebin.com/7fcXEJvV which I try to fix by changing “struct __utimbuf64 ut;” to “struct utimbuf ut;”. And then the last error, which is the one you replied to: https://pastebin.com/knqeDaq4


#103

If five accepted posts is still a requirement for creating a topic, I strongly object. This encourages posting low-effort comments and some potentially valuable contributors don’t hang around long enough to ever share their insight.


#104

I need to post a topic because I cannot get to 32x gpu rendering on the BEETlE PSX HW 0.9.44.1core


#105

It keeps us spam free.


#106

Internal resolution is now capped at 16x. 32x is not appreciably different from 16x, tbh.


#107

is there anyway to get it to work with 32x? Why did it get capped and when did it? i imagine it can make some difference on big 4ktv’s


#108

16x is 3840px for 240p content, but PS1 frequently jumps up to 480i, pushing it to 7680px. With 32x, that’s 15,360px, which crashes a majority of GPUs by exceeding the max texture size.

This is hard for people to correct if their GPU can’t handle it, since the BIOS animation is 480i and it will crash before they can get back into the menu to fix it.


#109

ok, that makes sense why it was removed, but is there a certain version of Retro Arch and version of Beetle PSX HW to get the 32x option?


#110

Sure, just build any revision prior to this commit:


#111

I have a gtx 1080… Is it worth me trying? i don’t know what you mean when you say just build a revision prior to this commit. is there a config file i need to download and put in one of the folders?


#112

It has to be compiled from a source snapshot from before that setting was changed. Unfortunately, we don’t keep old revisions of cores lying around.


#113

So you can’t give me steps on how to do this now, because you don’t know of an older version of the beetle HW core that supported 32x for download? I also think there should be a 24x option. There should just be a warning of needing an 8gb vram card for the 24x and 32x option.

https://www.libretro.com/index.php/tag/parallel-n64/

You guys were really pushing to the absolute limit in July 2017 when this article was post… Even saying you could get a 19x 12k resolution in Dolphin and maintain 60fps no problem… I notice you guys had an 8x internal res as a setting in dolphin before and now it’s just 6? Why are we going backwards lol


#114

Twinaphex had just gotten a Titan GPU and was basing those settings on what he could push with it, not realizing that it would put many users into a difficult spot if they tried the same based on his experience. It was creating a support burden, so we removed the options, which produce diminishing returns at very high scale factors, anyway.

The steps are: set up an MSYS2 toolchain/environment (assuming windows), fetch the source from github, checkout the desired revision, compile.


#115

I won’t be able to figure out what to do, so i will drop it. For Snes9x, what is the latest core? I see a 2002,2005,2010 version and just one that says Snes9x… I am reading there was a 2016 version, so it that the core that just says Snes9x? Do you know which version has the highest internal gpu scaling?


#116

Snes9x and other software-rendered cores don’t have any concept of internal resolution. They will always be scaled up to fit your screen using bilinear or nearest neighbor or whatever shader you decide to use (e.g., scalefx and xbrz if you like smooth interpolation instead of sharp pixels).

As a rule of thumb, cores with years after their names are old snapshots that you should typically only use if the one without a year is too slow on your device.


#117

I cannot use 16x gpu internal wth xbr texture filtering, without beetle slowing down. So i guess trying to get 32x is pointless, if i cannot even max 16x


#118

The PPSSPP core is not showing up in the online updater?? What do I need to do to download it?


#119

If it’s not showing up in the online updater, it usually means it’s not available for your platform.