How to emulate Lakka through a virtual machine?

My specs are:

64-bit Windows 10 Home Acer Laptop 900G hard drive 2.20GH Dual Core Intel processor NVIDEA Geforce graphics card

(I know that VirtualBox is obviously out of the question)

You can’t, the virtual machine image isn’t supported at the moment

Arghhh!!! That’s horrible!:sob:

If you don’t mind me asking, why would you want to emulate Lakka in a VM?

for research. I actually tried it a few days ago but realized it was an img not an iso

I have an Acer which is notorious for not allowing you to boot from a external source and Lakka isn’t capable of dual booting. Plus my computer offers more power than my Pi 3b.

Can’t you just use retroarch on Windows?

1 Like

There are . ova files provided by the build system, e.g., but we do not test them.

1 Like

I had trouble emulating that too. If you know how to do it on virtualbox I would be grateful to know.

How would I use .ova files as an .iso?

For example, you can import .ova file into VirtualBox But I am not sure if the required gpu drivers are included.

Lakka uses KMS for Retroarch which VirtualBox does not support.

At most you can use the CLI to browse the filesystem, etc.

I have done this myself for experimenting. It is not worth pursuing for anything else.

Emulating what? RetroArch can work as a standalone program on Windows

1 Like

@natinusala I think this topic is solved in the other thread:

It is. I’m trying to delete this thread.

I got mixed up about that. I was mistakenly thinking it was an OS like Lakka. :man_facepalming:

@MYSTfan21 the forum user @talbot posted something that might be the solution you are looking for.

I never used it myself

Lakka is running perfectly in a QEMU/KVM container by it self. i created a SMB share so lakka could fetch 250gb of roms. I allocated a 10gb vdisk and its only using 2gb. I will check again in a few days after its done collection its covers and such

Can you please share your exact QEMU VM settings? I cannot get it work and I’m stuck at the beginning, on flower (after successful installation). I would really love to run Lakka on my NUC with Proxmox VE.

I discovered how! Try using another OS on VM (like Linux Mint, Windows, Ubuntu…), on Settings > Storage add a 4 GB VDI disk (on the other os vm, not in lakka vm) On the VM download Etcher and the Lakka Image, flash the image on the 4 GB disk (if you put the disk with the normal os disk etcher will advise you about you’re flashing a system drive) and when complete, shutdown the vm, disconnect the disk and in the settings > storage of the lakka vm connect the disk as IDE Primary device 0 and power on the vm, type “installer” and install lakka on the virtual disk, when complete, shutdown the vm, disconnect the disk and set the disk where lakka is installed as IDE primary 0 If it doesnt work, try changing the vm settings