How to run DOSBox?

Total noob question here, but google isn’t really giving me anything.

I’m trying to follow this page from the Lakka website:

I have my MSDOS game. It has the .exe file and some other files.

How do I make it so that Lakka sees it?

Just to try, I put all the ms-dos files into the roms folder and then chose “scan this directory”. It froze. I had to unplug the power source and I just got my RPi 3.

Anyway, can someone in layman’s terms explain the correct procedure?

Thanks in advance

As the documentation said, you need to create a playlist named in the directory /storage/playlists.

Then in your game directory you need to create configuration file to launch it.

For example,


@echo off
mount d "/storage/roms/dos/tyrian"


After that, you should see DOSBox icon.

I almost got it. I just need help with a few more details.

I see the MS-DOS column and my game but it says cannot load from the playlist

in the line “storage/roms/dos/tyrian” is tyrian a file in the dos folder? or is it a folder within the dos folder with the file tyrian inside of it?

my game is in a zip file. keep it that way or take out the .exe file and just use that?

After I get that all squared away, to add a second game, I just need to edit the playlist and add the same 6 lines but with a different title? maybe use a space in between and then create a “conf” file for it in the same folder that the game is in?

sorry for all the questions, as you can see, I’ve already flubbed.

Yes in the line “storage/roms/dos/tyrian”, tyrian is the game folder.

You have to extract your archive to your game folder.

Yes right you need to copy the 6 lines and change the first (path to the configuration file of the game) and second line (name of the game).

No problem you are welcome.

Sweet got it working, almost. haha

It’s asking which drive to install the game to, such as C:

I typed in C: and it says it’s not available.

What is the default Lakka DOSBOX drive to install to?

Is it D: ? The other drive letters are saying there isn’t space available.

I tried another game. I pointed it towards setup.exe It let me to the DOS setup screen, where you can configure the sound card and controls. I saved the settings and wound up in a command line (D:) I know that the game is rap.exe so I typed that in, pressed enter, and it just reboots LAKKA.

reference gouchi and…

***…conf you can test in WINDOWS DOSBOX EMU (attention path in WIN and LAKKA is different ) If it run ok, then write your DOS.LPL

In my case the core won’t even start

I cant start the dos box to !

@carlosagh & @3devangelist : On which Lakka version and platform ?

Build date: dec 21 2016 Git version : 247b40f~

compiler gcc (4.9.2) 32bit

@3devangelist Is there any reason you are using an old build ? Can you try to make a test with Lakka 2.1 ?

i have it installed on a arcade machine made by me, and i have used a old core2duo laptop, the original monitor was broke, the i used one VGA 4:3 17", and i have to change the config file to config the second monitor, in these new releases i cant find the line to change . :smiley:

Lakka 2.0 runnin retroarch 1.4 i think…

I tried on Lakka 2.1 x86_64, it is working but I tried on Lakka 2.1 i386 and it didn’t work.

I tried with the core provided by the buildbot and it is working. We are using the same commit for the build.

In the time being, you can try to copy the core to Lakka. The time we fix the issue.

I just downloaded Lakka 2.1 and ran DOSBox.Many of my games run very slow and ugly, how do i configure DOSBOx???

@carlosagh please read this documentation to check if you need special configuration for a game. Also, you can change cpu cycles in the quick menu > options.

when I put the path to my conf file, it says “No executable file found”. my conf file contains the [autoexec] section that very clearly loads the exe, and I verified the exe is in the folder expected.