How to update cores in lakka(PI 3)

Sorry about my english is not very well.

i install lakka 2.1 img on my rassberry PI 3. i’d like play some psp game,but i found is not newest i hope to update cores directly.

but there is only a sub menu “update lakka” in the “Online updater” menu that i can choice. it’s not same like i run retroarch on ubuntu. in there i can find the menu of “update cores”

and i also found a config file placed at “/etc/retroarch.cfg”.it looks can setting params for retroarch. but i can’t modify this file, it prompt that file is read only.even i killed proccess of retroarch.

how can i update the cores of retroarch in lakka ?

thank you so much~ c0dedb2dd42a28349182063657b5c9ea15cebf6b

Lakka is distributed as a bundle for support reasons. If you want to add additional/newer cores that aren’t in the bundle, you can download them from and put them into the ‘cores’ directory in your user partition.


i had put scph5500.bin,scph5501.bin,scph5502.bin in /storage/cores,that make playstation game run properly.

but i put version,file size 9M) in cores folder, it’s not working. i thought this file should be placed in /usr/lib/libretro/, is that right? and i can’t move file,file size 5M) in /usr/lib/libretro/. it also prompted “read-only file system”.

so i hope find a way can update cores file on can download newer version of all “.so” file

thanks for u reply!

With Lakka you put the newer core and its matching .info file in the Cores folder. The new core file in the Lakka cores folder then overrides the “default” read-only version of the core in /usr/lib/libretro.

You cannot put a core file into /usr/lib/libretro yourself.

1 Like

i try that way to put file in /storage/cores. the files in /usr/lib/libretro haven’t been overrided. but the files in /tmp/cores have been changed. and when i load psp core in lakka, it has been changed too. i copy those “.so” files from retroArch runs on ubuntu system.i thought it might not suit for lakka.

where can i find for lakka? i only can get from but there is no “.so” files on that website.

thank you so much!

is any possible to re-use the “core update menu” on lakka?

/etc/retroarch.cfg file is read-only, is there any way to modify it?

The cores in /usr/lib/libretro should not change. This is not what it means to override it.

If a core exists in /storage/cores then it takes priority (its loaded, rather than the read-only one) It does not eliminate/remove/overwrite the original core, its just used instead. This allows you to remove the replacement core. and go directly back to the original again.

the cores files i copyed from retroarch runs on ubuntu system is not run properly in lakka.

where can i find right cores files for lakka? such as “”. I can’t find them on there are only “” files on that website. thanks!

there are some additional files in cores folder, but don’t have any “” files.

i found cores files on finally.

but PPSSPP’s cores file only can get from “nightly/linux/x86”. it’s not existed in “nightly/linux/armhf”. is that means they don’t suport it on arm architecture… Saddly i running retroarch on rasberry PI 3 :frowning:

thanks to all buddys

from chinese? retroarch.cfg file is in /storage/.config/retroarch.cfg or \lakka\Configfiles\retroarch\retroarch.cfg When the editor is done, “sync” and “reboot” are required.

I also tried to get an updated core for PPSSPP, but couldn’t find one in the Linux builds… not a recent one.

I’ve got two PSP games that start on a black screen and stay there… If I press the B button they make some sound, but that’s about it.

I wanted to open a proper new topic, targetting PSP only, but I can’t create new topics just yet :roll_eyes:

May I ask if matching .nfo files are required? I’ve compiled a newest wip version of lr-fbneo core by myself and I don’t have a .nfo file. Thank you

info files are needed for the core suggestions that happen in ‘load core’ and for showing the “pretty” name (e.g., Final Burn Neo instead of

1 Like