Integer scale on or off?

With crt hyllian and crt royale shaders I use the integer scale on.

Is there a way to have the image stretched proportionally until the top and the bottom of the screen?

The integer scale is really necessary for the hyllian and royale shaders?

Thanks!

You can go to settings > video > and set the aspect ratio to ‘custom’ and then with integer scaling enabled, put the custom width to 6x and the custom height to 5x. This will be slightly larger than a 1080p screen, but the part that gets cut off is well-within the area that would have been cut off on a CRT TV.

2 Likes

How did you calculate these values?

Thanks!

It’s just the closest >4.5 integer multiple to 4:3.

1 Like

I was going to ask the same question yesterday. I also use CRT -Hyllian and I have Integer Scaling turned off and aspect ratio set to Core Provided and I don’t notice any issues. The scanlines still look right to me.

Looks right to me too…

If you look at a solid-colored screen (especially gray), you can see there’s a pattern where some lines are darker/fatter than others at non-integer scales. Some shaders are more obvious about it than others, depending on how they create their scanline effects, but all of them will have this variation to some extent. How dark you make the lines will have an effect on it, as well. Whether the variation bothers you or not is subjective.

1 Like

Which CRT shaders are recommended to be used with integer scale on?

Thanks!

All of them look better at integer scales, but phosphorLUT looks very bad at non-integer. I think crt-caligari looks pretty bad, too. crt-nes-mini is another.

1 Like

I’m not sure how well this screenshot of a non-integer video with CRT-Hyllian will show up, but I don’t notice any differences with the scanlines. Maybe I just can’t see it.

Yeah, it’s really subtle. Here’s a zoom-in of your pic with the brightness and contrast increased:

Ideally, they should all look like the first dark line. That is, one dark line in the middle with equally lighter lines above and below. Skip down 3 scanlines and it’s just 2 mid-gray lines next to each other. Skip down a couple more and we’re back to normal. Rinse/repeat all the way down the screen.

It’s an effect caused by the averaging of the pixels into an uneven integer multiple (that is, 4.5x at 1080p). The remainder comes out as uneven gradients.

EDIT: here’s the same image with the green-tinted lines taken out to make it easier to see the effect:

2 Likes

Now I see the difference perfectly. :sunglasses:

1 Like

Very interesting. Thanks for making it clear.

1 Like

I tried your settings with integer scaling turned on with a 1080p screen, but the aspect ratio looks 16:9 and not 4:3. How do I make it 4:3?

Hunterk, please, see if I understood.

NES output is 256 x 240. For 1080 screen if integer scale on, the max. resolution will be 1792 (256 x 7) x 960 (240 x 4). To don’t have black borders, I have to increase the value for more than 1920 x 1080, resulting in 2048 (256 x 8) x 1200 (240 x 5). But is 16:9. How maintain 4:3 aspect?

Thanks!

Lol! I think we just asked the same question.

This is what I was describing (that is, still some pillarboxing but no letterboxing, and even scanlines):

There’s no logical way to keep a ~4:3 pixel aspect ratio on a 16:9 screen without cutting off lots of screen from the top and bottom. However, we do have support for overlays, which you can use to add images around/on top of the screen, and border shaders that can apply moving designs to the unused area.

1 Like

Yes, ndavis82. :laughing:

Makes sense. I still really can’t tell the difference with integer scaling off, the scanlines still look crisp and nothing looks warped, and at least with scaling off the screen will always maintain a 4:3 ratio. I think I’ll just keep it that way. Thanks for taking the time to explain.

ndavis82, I decided to maintain the integer scale “on” with custom aspect ratio: 1536 x 1120.

Better than the fully stretched image.

:smiley:

1 Like