Intel HD600 -- no video in 4K! Please help

I asking for assistance to make my system work! I’m trying to get 4K video from ODROID-H2 using current nightly build of Lakka. Sys configuration: 4 core Celeron x64 CPU 16 GB RAM Intel HD600 internal video, HDMI 2.0 supported 4K TV connected by “high speed” HDMI into HDMI-A-2 port

Previously, video does not work at all. I fixed it by adding a “i915.alpha_support=1” parameter into boot config. And then tested it with HDMI-to-VGA adapter in 1920x1080 resolution, everything was fine. But then i connected the thing to 4K TV and get nothing but black screen after boot. SSH works BTW, so the system boots, hmm… well, except for the video.

I tried to set another screen resolution in retroarch.cfg, but with no result((( Currently using Win10 in Kiosk mode with certain FPS drop, broken audio and overall performance loss in 5% (because of inactive retpoline?)

Maybe there is the documented way to update kernel (to 4.19+), xorg or Intel video driver? Please tell me!

Fixed by installing this build: “i915.alpha_support=1” no longer needed.