[iOS] — RetroArch 1.7.8 and other emulators (Download)

iOS Emulators :

You can use my website : iOS Emulators ! :wink:

iOS Emulators repo (Jailbroken) :

If you’re jailbroken, you can just add my repo to Cydia by clicking this link on your jailbroken device, (this link for Sileo) or by adding this source to Cydia : http://johan.margueritte.free.fr/repo

I created a buildbot too specifically for jailbroken iOS 10 & 11+, and for iOS 6 to 9 jailbroken or not ! It is already configured in my RetroArch downloads…

iOS 11+ buildbot : (64-bit)


iOS 10 buildbot : (32 & 64-bit)


iOS 9 buildbot : (32-bit)


iOS 6, 7 & 8 buildbot : (32-bit)



Hi! PPSSPP is not optimized for ipad pro 11 screen Thanks!

@thefakesound Yes, PPSSPP is faithfully emulating the PSP’s 16:9 display, on the iPad Pro’s 4:3 display…

But they recently implemented iOS’ native TV out, so it will be full screen on a widescreen TV !

(You can probably change PPSSPP’s aspect ratio to be 4:3, if you want to distort the image to fit the iPad’s screen, though…)

No, I mean like app itself not optimized for 11 screen. Harakari2 said he updated RetroArch for iOS to use “Launch Storyboards” instead of “Launch Images” - this had help. On ppsspp forum someone posted fullscreen 1.8.0-100 version

@thefakesound Oh ok, I understand… I will try to compile the latest version and update it, but I’m still in the process of updating RetroArch’s buildbot for iOS 9 and iOS 10, manually…

(With so many versions just for iOS, updating only RetroArch takes quite some time… :smile:)

I’ve read in your web that all the files are signed. Just for curiosity, with your own Apple developer account? In the other hand, a jailbroken device could run unsigned code, so signing the IPAs is not needed, isn’t?

@diedel I sign all IPAs just for the sake of it (and compatibility with all jailbreaks, old and new, if people prefer to install manually from the IPA, even if they are jailbroken…)!

Mostly I have to “sign” the emulators on the repo with “entitlements”, which are required for the emulators to access the whole filesystem, and not just the randomly named sandbox folder (for which I couldn’t include most of the assets)…

(The entitlements look like this) :


Sandboxing hampers the flexibility of installing/uninstalling emus without affecting saves, configs, ROMs etc… And it wastes precious space by backing up those files with iTunes or iCloud if they are included in an app’s sandbox, too!

Thanks for your explanation.

About the entitlements, I think that explains I couldn’t navigate the whole filesystem in the Retroarch 1.7.8 IPA from Harakari2, because it doesn’t have the corresponding entitlement.

1 Like

Hey @Weedy_Weed_Smoker are you able to add the bsnes HD core?

Just updated RetroArch and PPSSPP to the latest versions, compiled with iOS 13 SDK to fully support PS4 and Xbox One joysticks on iOS 13…

@sabin Added now !


And again, iPad Pro 11 not fullscreen

@thefakesound It’s the latest official PPSSPP version, maybe @harakari2 has a PR somewhere but I didn’t find it (neither on the official GitHub, nor on his or libretro’s)

I’m running into an issue on my iPad Pro 11" (3rd gen with 120hz screen). On default settings, the video is really choppy in everything, but after doing some digging I discovered that turning on “Sync to Exact Content Framerate” and setting the V-Sync Swap Interval to 2 seems to rectify this in just about everything. What’s strange though is it seems to make the issue worse under SNES emulation.

If I disable syncing to the exact content framerate, it makes it noticeably better (with the Vsync Swap interval still set to 2), but it’s still slightly choppy. It seems to be consistent across all three included cores as well. I made a short recording of the behavior here: https://youtu.be/YZafNdS1kQs

Simply changing the swap interval to 2 defininitely makes SNES playable, but I’m curious if you have any ideas on what I might try setting to get the video playing normally?

Also, thank you for all of your work! :slight_smile:

1 Like

hi @vtvincent!

I’m aware of the choppiness issue related to the 120 Hz refresh rate, and I’m not sure yet what to do about it. I’ll ask the devs on discord to see if this was specifically dealt with since some Android devices have 90/120 Hz refresh rates.

But your solution for the genesis core seems a little promising - thanks! I’ll try to find out more info.

1 Like

RetroArch keeps crashing on startup for me. It works perfectly first launch after I install, but once I close the app, it either hangs on startup or crashes back to the home screen when I go to launch the app again. My device is iPhone XS Max iOS 12.4 unc0ver jailbreak Thanks

@rx20na Do you use any nonstandard options in the Unc0ver jailbreak ?

I think you could try in the Unc0ver app, before jailbreaking, activating the “Set CS_DEBUGGED”, maybe “Export TFP0” if this still doesn’t work…

I’m not sure what changed with Unc0ver’s A12 jailbreak solution, but I’d like to solve this ASAP!

Thanks for the feedback…

Thanks for your response!! No I’ve got the standard settings set in unc0ver No luck with those options turned on. Still hanging on startup I also tried jailbreaking with tweaks off to see if anything I installed was doing it but no it’s still hanging. Is there anything thing else I can do to help you to find what might cause this problem? Thanks

Ok, do anyone else with an A12 jailbroken with Unc0ver experience this behavior ?

@rx20na can you try to take the assets.zip from inside the ipa version’s app, and put it inside your RetroArch.app on your phone ? (with Filza or such…)

I actually think it may run sandboxed on your phone, but then again you wouldn’t have a correct interface in RetroArch if that was the case…

Hey i found a cydia repo that upload the latest ppsspp dev build here https://halo-michael.github.io

and i made a 50$ bounty to fix jit for ios 9+ jailbroken device on retroarch: https://www.bountysource.com/issues/41472352-ios-dynarec-jit-ios-9-patch-by-qwertyoruiop

1 Like

@QcSamuel Yeah, this repo is from the guy who helped me compile PPSSPP for iOS in the first place…

@thefakesound maybe you can confirm if his latest version is looking fine or not on your iPad Pro 11…