Is there a tutorial on how to run PUAE at all?


#1

Tried really hard to make my winuae config (to run an hd with games on it) with puae but no availl.even loading adf seems impossible. isn’t there a tutorial otu there that covers the extreme basics for it?


#2

I don’t think the core really works. If you read through some related threads (ie [UAE core for Retroarch]) it seems there is a way you can make it work but it’s so impractical that it essentially renders it useless. It seems there is no enthusiasm to enrich the core, which is a shame since Amiga emulation is the primary reason I wanted to run RetroArch.

Secondary is ZX Spectrum (which the FUSE core runs mostly ok), PSX which the Beetle one runs perfectly well (once I disabled shaders completely), Atari 2600 (which is useable as long as I enable shaders to sharpen it a bit :confused: ) and BBC Micro (which nothing runs except MAME, apparently, which I can’t get working).

So all in all I’ve been a bit disappointed. I love the idea of RetroArch and the config/menu side works well but I might have to switch to Emulation Station or build my own launcher and go with FS-UAE for Amiga. A lot more work and not so neat, but will be compatible.

Unless RetroArch updates sort out my niggles in the future…


#3

Try this one:

http://lindqvist.synology.me/wordpress/?page_id=182

It works, I swear.


#4

Unfotrunately i have to agree with you. Winuae in itself is not particularly difficult to configure thanks to the ui, while this puae needs premade config apparently for EVERY adf file you need to play. Its a shame though because i like reotrach, especially now that i have a big 4k tv and i can play those games from my couch with a wireless joypad…

Thing is, i knew already how bad p-uae,. but i tried it anyway for one reason ,and one reason only: i noticed that retroarch nicely filter and resize every game i try, for any system, according to my tv. Winuae instead, despite many settings and countless hours spent tinkering…the screen looks grainy and incredibly pixellated on my big tv.

I tried making a post about it on lemonamiga forums, but of course nobody replied :\


#5

Actually, the p-uae core works decently, providing you use the build here: http://lindqvist.synology.me/windows/ (Windows x64 only, sorry). The only limitation that I’ve found so far is the inability to work with filesystem directories, i.e directories in the host system. There are two ways to load games in the P-UAE core:

For single floppy games or harddrives (bootable): you must have a valid configuration file called .uaerc in the same directory as Retroarch.exe. This is an example, emulating a vanilla Amiga 500 (with 4 floppy drives):

kickstart_rom_file=./kick13.rom chipmem_size=1 bogomem_size=0 use_gui=no nr_floppies=4 cpu_type=68000 cpu_speed=real cpu_compatible=true ntsc=false chipset=ocs immediate_blits=false gfx_linemode=double gfx_framerate=1 sound_output=normal sound_frequency=44100 sound_channels=mixed sound_interpol=none show_leds=true floppy_speed=100 gfx_center_vertical=smart gfx_center_horizontal=smart gfx_color_mode=16

(you must substitute the spaces with linefeeds, I can’t find how to format code correctly in the post editor)

Note the kickstart location: in the example above is ./kick13.rom, that means that the kickstart rom (called kick13.rom, and it’s Kickstart 1.3 since we target an A500) must be in the same directory as Retroarch.exe. Now you can load directly your .adf (or .hdf) file within retroarch and it should play (if it is Amiga 500 compatible, of course).

For multi floppy games, I think there is currently no other solution that write a .uae file yourself (or write a program that does that automatically!). You can use the above template and simply add the .adf images like this:

floppy0=C:\AmigaGames\Assassin.Disk1.adf floppy0type=0 floppy1=C:\AmigaGames\Assassin.Disk2.adf floppy1type=0

Then you can load the resulting .uae file in Retroarch.

Hope this helps.


#6

Try the link I’ve posted. You won’t regret, I swear.


#7

problem is that i need to write a config for EVERY adf game i want to play, and apparently multi-disk support is out of question…


#8

Yeah, you ned to write a config for every game. I wrote a batch file for do that for me. As for the multi disk games, read the entire tutorial, as he explains how to use whdload files… It is the only way…


#9

Hi, I can run MSX games just fine using MAME core from Retroarch (for savestates, not supported by BlueMSX). I can show you how, just need some answers:

  1. Can you run BBC Micro programs using standalone MAME?
  2. Are you familiar with MAME Software Lists?

And The last qyestion: which shaders do you use with Stella?

Thanks un advance


#10

you have a script…i don’t, so its not easy for me, and not convenient at all.

I read the tutorial, still not convenient…especially for the fact that you use whdload files…which runs fine and immediately on winuae


#11

WHAT??!

what exactly are you talking about?

i never said i use Stella, or msx


#12

Sorry, my mistake. That reply was for other dude, Esc.


#13

It is the only way, sorry. I’ve searched for months, with no success. This is the only way, now my Shield TV runs amiga from Arc Browser smoothly.


#14

Hi everyone,

I recently updated the puae core and now it can work without the need of a specific .uae file for each game.

You will have more infos in the following thread:


#15

Thanks I’ll give it a try


#16

OK tried it and it works basically perfect!!

so perfect that i didn’t even needed to create a m3u file for multiple disks…pressing X on my xbox controller opened up the puae menu (this time perfectly usable\browsable), and there’s a “floppy” disk option where you can swap disk on the fly…and it works perfectly! the only downside is that the files must be extracted adf files (retroarch can read zip files but not the puae menu) and they must in the C: hard drive (or the hard drive letter where you installed reotrach), no matter the folder


#17

Glad to hear this finally got some much needed attention, does it now also work correctly on linux or is that still broken?