Isolating overscan options in image-adjustment


#1

So I’m wondering how one would go about editing the image-adjustment.cg shader to remove or at least disable all of the functions that don’t have to do with the overscan and X/Y adjustments. I find that, in my current situation with shader setups, it would be very handy to have a separate overscan-adjustment shader.


#2

At the top of the file, there are a bunch of lines that start with #pragma parameter. Just delete the ones you don’t want and they should disappear from the list.


#3

That doesn’t work. The resulting shader just gives me a black screen.


#4

For each parameter line you deleted, delete the corresponding lines that say ‘uniform float $whatever’ and move the corresponding #define $whatever number down to be outside of the #ifdef PARAMETER_UNIFORM


#5

Okay, thanks. Now the shader’s up-and-running and integrated into my preset, though I did run into a weird problem where the final shader (crt-royale-geometry-aa-last-pass.cg) would cause the screen to go black except for this white bowtie-shape sticking out of the right side. Dunno what that was all about, since the overscan-adjustment shader seems to work just fine, but I managed to get the screen back to normal by changing the final shader’s scale from “1x” to “don’t care”, which otherwise didn’t seem to affect the look of the preset at all, so issue resolved, I guess. :man_shrugging:

Anyways, thanks again.


#6

Okay, so now I have the same question again, except this time for the GLSL version of image-adjustment.


#7

The same procedure should work. Delete the #pragma parameter lines you don’t want, delete the corresponding ‘uniform COMPAT_PRECISION float’ lines and then move the #define whatever lines down outside of the #ifdef PARAMETER_UNIFORM block.


#8

Okay, thanks. I tried doing that before, but when it didn’t work, I figured that the language was too different to apply the same changes. But now that I’ve tried it again, I realized that… Well, I’m honestly still not entirely sure what I was doing wrong to begin with or what exactly it was that fixed it, since GLSL seems to be a good bit more temperamental about messing with functions, but after persisting for a bit, I’ve managed to get the modifications to work, so that’s that done with at least.


#9

I realize this was ages ago, but I’m trying to accomplish the same thing and I’m not having any luck. Do you happen to have the file you used?