Issue with Kronos Saturn emulator

I’m trying to use the Kronos emulator. When I load a game, the BIOS sound plays and the game audio starts but there is just a black screen. Anyone else come across this?

My guess would be a gpu with bad opengl support. What’s your gpu ?

Currently using a Radeon HD 7790. I also have the option of using integrated graphics from an i3-7100 but haven’t tried that yet.

Switched over to integrated graphics and that fixed it. Thanks for the reply.

Probably yet another issue with mesa drivers, because kronos works properly with proprietary drivers.

Could you post logs ?

Oddly enough, I had this issue when I used OpenGL CS. Have you or anyone else had issues with flickering during loading times of the games?

Looks like the issue you get when you use “gl” as video driver, make sure you use the “glcore” video driver in retroarch settings. Nowaday the core would force it, but latest lakka release (2.3.2 ?) seems to be almost 1 year old. Maybe you should use the nightly builds (