Joypad issues

I just flashed a fresh Lakka for a RPi4, and having trouble identifying some controllers.

Xbox one with wifi adapter doesn’t register at all.

Original PS2 dualshock via a usb adapter gets power but won’t bind.

What does work is a Hori Fight Stick PSX using the same usb adapter that won’t work with the regular PS2 controller. Also a wired regular Xbox 360 controller works just fine.

For some reason, I also don’t see a way to update the joypad profiles. That’s been there in the past. Also, these other joypads have worked in the past. Any ideas?

Thanks

Hmm, you should be able to update the autoconfig profiles from the online updater. If you don’t see that option, check settings > user interface > views and make sure it’s not hidden. Either way, you can always download the profiles from http://buildbot.libretro.com/assets/frontend/autoconfig.zip

Yeah, I have the Online Updater option enabled in Views. Downloading and dropping this folder into .config/retroarch/autoconfig doesn’t seem to change anything.

I also don’t seem to have the ability to add cores, but it also seems like everything was already loaded there. I sometimes forget if that’s standard for Lakka vs vanilla RA.

Yeah, still can’t use my Xbox one controller. It’s supposed to just connect to the wifi dongle if my memory serves me correctly.

Yeah, Lakka bundles its cores rather than pulling them from the buildbot nightlies.

And yeah, it should just see the adapter and recognize the pad :confused:

I don’t know then. I guess I can start from scratch. I was using the Jan 21 image of Lakka-RPi2.RPi4.arm-2.3.2.img when I flashed.

I also tried dropping the whole udev folder in /joypads/udev and that also had no effect. Should there be an autoconfig.cfg file in udev? I don’t see one.

AFAIK, the location should be ~/.config/retroarch/autoconfig/udev.

So, when you plug in the controller, it says “blah blah gamepad configured or not configured”?

The Xbox one controller says nothing when I plug in the wifi adapter. It works fine in my PC.

My PS2 dualshock says it’s a sega saturn usb controller, and it doesn’t work. The red led will come on if I press the little analog button.

Hmm, if the xbone pad doesn’t even recognize that it’s getting plugged in, there’s not much to be done, unfortunately. I think it would need another driver, but that’s not something that’s easily done via Lakka.

If the PS2 adapter recognizes it as a sega saturn pad, it means it’s using the same vid/pid as some USB saturn pad. If it responds at all when listening for inputs in settings > input > port 1 binds, you can re-bind it and save your own autoconfig profile for it, which should supersede the old one (I think).

1 Like

The PS2 controller does not respond at all when I try to bind it. With or without the analog button depressed.

I don’t know that going back to a previous image is going to do me any good. I am willing to bet that I’ll have the same situation.

I guess I’ll just use the Xbox 360 controller and the Hori stick until there’s another update and hope that one sees my Xbox wifi dongle

1 Like

Did you try to use this option ?

It is still not working, we may have to package this driver ?

Thank you.

1 Like

Did you try to use this option ?

I believe that is for bluetooth. I’m using an earlier Xbox One controller (no bluetooth) with a Wifi adapter. The main Lakka site says they are supported out of the box and I just have to plug in the adapter. It works as expected on my PC.

It is still not working, we may have to package this driver ?

So, I think the old driver worked in the past. This strikes me as something to do with the autoconfig process and less to do with the available drivers. Autoconfig is misidentifying my PS2 controller (as a Sega Saturn or PS1 controller which are electrically similar) and failing to recognize that I have plugged in my Xbox One Wifi adapter.