Just Updated Retroarch Again, Now shaders don't Work Again


#1

Upgraded to the latest retroarch build so that I can take advantage of the reicast improvements. Now the shaders ive been using no longer work right. If I revert back to the build from before, they work again. What changed so that I can fix it?


#2

I wasn’t aware that anything in Reicast required a new RetroArch build, but post a log and screenshots of the changes and I’ll try to help.


#3

I was using reicast oit from june 27th. everything works fine there. I switched out oit with the only reicast I found in the download section now just called reicast. Any game I play now results in a black screen even in the menu but I can still hear the game. If I use the new reicast in the old retroarch of june 27th, I just get a crash. If I use my shaders after the game has started, the cg files dont show up and nothing happens when I try to use the glsl shaders. That oit in the new retroarch works fine.

LOG (new reicast in new retroarch) https://mega.nz/#!WpExSS4Q!wACG-zTZnDdiDi-QI3GxiutnUMjCw8uudFxADEFlSKs

(old oit in new retroarch) https://mega.nz/#!u8N3lSRS!api8Ye5HS71HEyl4c16yJhEhA76LCMIcf2t0usGQuhE


#4

I’m pretty sure Cg shaders don’t work with it anymore, at least not reliably. You’re likely to get a black screen. Switch to GLSL shaders instead.


#5

I tried the glsl shaderset I had. Works with old retroarch and reicast oit, they don’t load now.


#6

Ok, post a log and screenshots and I’ll try to help.


#7

nvrmnd, I must have done something wrong last night. the glsl shader version seems to be working now. thx

However, this was a shader set you helped me convert in the past in which you said something about the menu of them wouldn’t be able to work at the time (i dont remember why). Those glsl shaders have no options in the menu. Would it be possible for you to edit them to have items in the menu now instead of me manually adjusting the values through the files?


#8

Which shaders are they?


#9

https://mega.nz/#!L0V0ACxT!ACWPamVyfrO7nTNq9QYCur0dvXrS3beJLrSE-URyWbI


#10

The problem appears to be with the aa-shader-4.o.glsl shader pass. Replace it with the hand-converted version from the repo and you should be good.


#11

I switched it out with the aa-shader-4.0-level2-pass1-noblend.glsl version and still nothing happens. EDIT: nvrmnd, I saved it wrong xD

Thanks hunterk!

But can you make it so that the other shader options show up in the retroarch menu for glsl?


#12

Also, did I have to do this for .cg and .slang as well?


#13

I’m not sure what you mean by this. If the shaders lack parameters, they’re probably outdated, machine-translated versions, which you should be able to replace with the official supported versions that I hand-converted.

only if they don’t work, I guess.


#14

They lacked parameters because there were no glsl versions at the time and it was a conversion from cg. Either you or Guess.R said at the time that parameters wouldn’t show. I forgot why. But for scalefx, I like the older version better because it is identical to xbrz and the new updates are a little off so I would like to keep what I have (no parameters are only in the glsl version of mine btw). And some I can’t find in there like blur-gauss-h.glsl and blur-gauss-v.glsl that were converted for me from reshade (haze effect).


#15

I would recommend seeing if there are hand-converted versions of any of those shaders now, as I think I’ve converted all but a few now.