Koko-aio shader discussions and updates

Hello, first of all I want to thank you very much for your splendid work, which has allowed people like me, not equipped with particularly performing PCs, to have truly excellent visual results with Retroarch. I mainly use your monitor shader, but I noticed that I have a strong reddish tint when using it, and it gives me the perception of offsetting the general colors a bit. Where can I adjust the shader settings to dim it? I hope you will follow the project and make other updates, in the meantime thank you very much for your attention and your precious work.

Hi there,

thanks for your kind words; trying to make koko-aio lighter enough to run on integrated consumer igp was one of the main goals, so I’m glad to hear it is working fine on your system too.

Can you post a screenshot to better show what is the issue you’re referring to?

Sorry if I’m replying late. I’ll give you some screenshots I just took :

Definitely weird, I’m unable to replicate the issue; since is evident in the PSX bios Logo, I installed Beetle PSX HW and bioses, then started a a test program and stopped at the bios logo, but my screen is fine, no reddish tint. What koko-aio version are you using?

Since some time it is available in retroarch under shaders/bezels. Please, update shaders and try from there too and let me know!

I use the version present in Retroarch, all updated to the latest version. I use the swanstation core for Playstation emulation, but trying other cores the problem remains. I also tried using GL Core video drivers instead of Vulkan, but again nothing. I also downloaded your package from Github as a last try, but nothing. Of course, the video card drivers are also up to date.

So we need to isolate the issue,

If you enter in the shader settings while a reddish screen is displayed, you can selectively disable or enable the shader features (0=disable, 1=enable).

The switches are marked by a star symbol, eg:

image

Please, try disabling one by one and see if the problem goes away.

Done, I modified an item, saw the result, then reloaded the shader and tried another item. I also tried turning off the color correction. All useless, even if this reddish halo remained in the background of varying intensity. I’m starting to think it’s an ATI driver problem.

You can just disable all of the items and see if the reddish tone remains, it is faster. However, if you did it one by one without success, unfortunately I think that the issue lies in the driver. Being myself on Linux, I fear I can’t help you much more. But even if it is not a perfect solution, you could try to tweak the color temperature setting to a more cold value (try around 7200k). This will lower the red tone more and probably a bit of green, but maybe it will be still an improvement.

Out of curiosity, what’s your hardware?

1 Like

I have a mini PC AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx and 16 GB of Ram, and I use Windows 11 as an operating system. However the situation has improved slightly following your advice, even if I am convinced there is some driver problem with the Ati. Anyway thank you so much for your help and please continue this project which is great. Thank you

2 Likes

Hello, I wanted to let you know that I have located the problem at the root of my reddish color. Under “RGB Masks and/or Darklines enable?”, if I deactivate the “(LoDPI) Green, Magenta - BGR” option by setting it to 0, the problem disappears as if by magic :slight_smile:

Ahah!

So you didn’t really deactivated all of the switches :slight_smile:

Also, this does not explain why I see the same reddish tone in the psx logo screenshot you posted.

My bet is that your screen is running a scaled resolution somehow… I’m on mobile right now, tomorrow i’ll check better.

Anyway, being you on 1080p, if you disable that green/magenta trick, i suggest you to disable the gap between the triads too to keep more brightness.

2 Likes

Scusami, ma ero convinto ti fossi riverito solo al primo gruppo di opzioni, errore mio. Appena posso proverò il tuo consiglio di disattivare the gap between the triads. Ti ringrazio per il tuo prezioso aiuto.

Continuo in inglese per chi legge :slight_smile:

I confirm that you screenhots are reddish, but the same shader settings are fine on my monitor. So I invite you to double check that you are running your system at native display resolution and that Windows (or the ati driver, maybe) is not scaling it, because that would explain everything.

If it was the cause, you could achieve much, much better results by fixing it.

If I were on Windows, or you on Linux, I could give more assistance in detail.

Excuse me, I’m Italian and I don’t speak English very well and I use google translate to help me, and I copied the untranslated text. I try immediately.

However we found out that it’s my problem and not your shader’s, I guess I’ll format the PC and see what happens. Thank you so much for your help and I hope our conversation is helpful for some other users with the same problem. I take this opportunity to ask you what you have in store for us with the next updates, if you can give us some anticipation. In the meantime, thank you, you have been very kind.

1 Like

Next release will have

.An additional improved and moiree free slotmask by default that follows the scanline width (already in git)

.Probably a new parameter to balance the halo versus the scanline and slotmask strength

.Maybe changing the way the scanline weight is handled (unsure)

.Last, I’ll try to insert proper ntsc co/decoding, but this one will take time, because I’ve still no clue how the thing works, and I’d like to figure it out by myself how to implement it, just to keep the coding fun :slight_smile:

2 Likes

@kokoko3k Recently I update the default shaders-slang package from retroarch and there is a koko-aio folder inside of the bezel’s folder. Is this a official release from your package? Why there are different presets like tv-base?

Hi,

the one present in retroarch is the release v3.0 present on github.

As for the second question, I’m not sure i got it, the presets on retroarch match the ones on github for v3.0 (I plan to update the ones on retroarch on next stable release from github), so I answer the obvious way: pick the one you like more, if any!

Edit, maybe I got it:

*-base presets are the ones on which others are based on. So eg. monitor-bloom preset is monitor-base with bloom added and so on. They make (more) sense in the main git repo, where the presets are just references to the base one, this allows me to change a setting in a base preset and that setting affects all the ones that reference it automagically.

This (shader preset referencing) is not allowed for shaders shipped with retroarch, so every preset have to contain all of the settings needed for it to work. and eg. monitor-bloom is a duplicate of monitor with another switch/parameter applied to it.

However I decided to keep them to give users a base to tweak their own settings, so they are still handy somehow.

I hope I’ve answered to the question.

Thanks, This is a very promissing project, probably the best in terms of quality vs performance. I use the preset tv-BASE.slangp, it serves for all my cores. I have an issue with Mame core which I tried every “Aspect Ratio Numerator”, the “-1” is ok for horizontal games, for vertical I can’t find a solution, even “-5” does not work with every game. Is there any recommendation for a single configuration that serves for both horizontal/vertical games?